Problem in configure with trunk 10632


#1

checking for xdg-mime… true
checking for Python >= 2.5… yes
checking for Python Cheetah templates >= 2.0.0… yes
checking for Python lxml wrappers >= 2.0.0… yes
checking for Python gtk wrappers >= 2.10.0…

^C^C^C^C^C^C^C^C^C^C^C

can’t control C either…

this has happened on an ubuntu intrepid box, and two FC10 boxes
independently.


#2

what does python --version give you?

what happens when you run python -c “import gtk” in the same terminals?


#3

Josh B. wrote:

what does python --version give you?

what happens when you run python -c “import gtk” in the same terminals?
ubuntu:
root@phenom2:~/gnuradio# uname -a
Linux phenom2 2.6.27-11-generic #1 SMP Thu Jan 29 19:28:32 UTC 2009
x86_64 GNU/Linux
root@phenom2:~/gnuradio# python --version
Python 2.5.2
root@phenom2:~/gnuradio# python -c “import gtk”
---- freezes as in configure

FC10 #1:
[root@phenom gnuradio]# python --version
Python 2.5.2
[root@phenom gnuradio]# python -c “import gtk”
---- same freeze

FC10 #2:
[root@evo2 gnuradio]# python --version
Python 2.5.2
[root@evo2 gnuradio]# python -c “import gtk”
---- same freeze


#4

Thats really bad!

howabout

python -c “import pygtk; pygtk.require(‘2.0’); import gtk”


#5

the same.

top doesn’t show anything eating up CPU, at all.


#6

On Tue, Mar 17, 2009 at 4:16 PM, Brett L. Trotter removed_email_address@domain.invalid
wrote:

top doesn’t show anything eating up CPU, at all.

Are you perhaps ssh’d in and have X forwarded over your network?

Johnathan


#7

Usually for stuff like compiling and it has worked in the past (even a
few days ago).
You’re correct, when I come on with VNC or console, it works fine.

Any idea what broke?


#8

On Tue, 2009-03-17 at 18:39 -0500, Brett L. Trotter wrote:

Usually for stuff like compiling and it has worked in the past (even a
few days ago).

You’re correct, when I come on with VNC or console, it works fine.

Any idea what broke?

No idea. But I’ve seen this happen before, unrelated to GNU Radio. Can
you try using ssh but with the -x option (lowercase, disables X11
forwarding.)

Johnathan