Problem getting rdoc documenting all top level module/classes in a file

Content preview: Hi, I’m struggling to understand how rdoc expects my
source
to be organized so it documents everything in it I want. Using ruby
1.9.2p180
and rdoc 3.6.1 and the following source layouts I’ve missing
documentations:
[…]

Content analysis details: (-2.9 points, 5.0 required)

pts rule name description



-1.0 ALL_TRUSTED Passed through trusted hosts only via SMTP
-1.9 BAYES_00 BODY: Bayes spam probability is 0 to 1%
[score: 0.0000]
X-Cloudmark-Analysis: v=1.1
cv=tMVj8KYobzzX0EiRnC7vY2isLrCxFvdg4RrHWPZXwJ0= c=1 sm=0
a=CPlwVjms4CEA:10 a=SrjczX2fzloA:10 a=IkcTkHD0fZMA:10
a=E9mgWNZsGXMqngZ3544A:9 a=01WvPIUv7XLrhmR3IxYA:7 a=QEXdDO2ut3YA:10
a=HpAAvcLHHh0Zw7uRqdWCyQ==:117
Mime-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 7bit
Precedence: bulk
Lines: 82
List-Id: ruby-talk.ruby-lang.org
List-Software: fml [fml 4.0.3 release (20011202/4.0.3)]
List-Post: mailto:[email protected]
List-Owner: mailto:[email protected]
List-Help: mailto:[email protected]?body=help
List-Unsubscribe: mailto:[email protected]?body=unsubscribe
Received-SPF: none (Address does not pass the Sender Policy Framework)
SPF=FROM;
[email protected];
remoteip=::ffff:221.186.184.68;
remotehost=carbon.ruby-lang.org;
helo=carbon.ruby-lang.org;
receiver=eq4.andreas-s.net;

Hi,

I’m struggling to understand how rdoc expects my source to be organized
so it documents everything in it I want.

Using ruby 1.9.2p180 and rdoc 3.6.1 and the following source layouts
I’ve missing documentations:

------------------8<-----------------------------
$ cat test2.rb
require ‘something’
=begin rdoc
findmeindoc
=end
module Foo
class Bar
end
end
$ rm -Rf doc && rdoc -v test2.rb
Parsing sources…
100% [ 1/ 1] test2.rb
class Bar (undocumented)

Generating Darkfish format into …
------------------8<-----------------------------

In this case, as soon as I put any kind of code above the rdoc of my
module, the module itself does not get processed anymore. However I
really prefer having includes and maybe necessary initializations at the
top. Because when I move it below the rdoc but before the module
definition, it works:

------------------8<-----------------------------
$ cat test3.rb
=begin rdoc
findmeindoc
=end
require ‘something’
module Foo
class Bar
end
end
$ rm -Rf doc && rdoc -v test3.rb
Parsing sources…
100% [ 1/ 1] test3.rb
class Foo::Bar (undocumented)
module Foo (undocumented)

Generating Darkfish format into …
------------------8<-----------------------------

Similar when I’ve two modules in a file, only the first one gets
processed:

------------------8<-----------------------------
$ cat test8.rb
=begin rdoc
findmeindoc
=end
module Foo
end

=begin rdoc
findme2indoc
=end
module Frob
end
$ rm -Rf doc && rdoc -v test8.rb
Parsing sources…
100% [ 1/ 1] test8.rb
module Foo

Generating Darkfish format into …
------------------8<-----------------------------

Can this be worked around? Basically I’d like it to document everything
have, except things I flag with nodoc.

thanks,

  • Markus

Content preview: Hi, On 28.05.2011 10:39, Markus F. wrote: > I’m
struggling
to understand how rdoc expects my source to be organized > so it
documents
everything in it I want. After some more tests and I short IRC
session it
looked to me as that it’s a bug and I’ve opened an issue [1], HTH.
[…]

Content analysis details: (-2.9 points, 5.0 required)

pts rule name description



-1.0 ALL_TRUSTED Passed through trusted hosts only via SMTP
-1.9 BAYES_00 BODY: Bayes spam probability is 0 to 1%
[score: 0.0000]
X-Cloudmark-Analysis: v=1.1
cv=vUpxTctd+kpWCBtSXXIkt5ll4Z8E5Qu9nLREXC/hfIo= c=1 sm=0
a=CPlwVjms4CEA:10 a=xzlJGzDX6TAA:10 a=IkcTkHD0fZMA:10 a=xqWC_Br6kY4A:10
a=NEAV23lmAAAA:8 a=l2z7s4bZjCe3Klm0sL8A:9 a=QEXdDO2ut3YA:10
a=HpAAvcLHHh0Zw7uRqdWCyQ==:117
Mime-Version: 1.0
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 7bit
Precedence: bulk
Lines: 12
List-Id: ruby-talk.ruby-lang.org
List-Software: fml [fml 4.0.3 release (20011202/4.0.3)]
List-Post: mailto:[email protected]
List-Owner: mailto:[email protected]
List-Help: mailto:[email protected]?body=help
List-Unsubscribe: mailto:[email protected]?body=unsubscribe
Received-SPF: none (Address does not pass the Sender Policy Framework)
SPF=FROM;
[email protected];
remoteip=::ffff:221.186.184.68;
remotehost=carbon.ruby-lang.org;
helo=carbon.ruby-lang.org;
receiver=eq4.andreas-s.net;

Hi,

On 28.05.2011 10:39, Markus F. wrote:

I’m struggling to understand how rdoc expects my source to be organized
so it documents everything in it I want.

After some more tests and I short IRC session it looked to me as that
it’s a bug and I’ve opened an issue [1], HTH.

  • Markus

[1] https://github.com/rdoc/rdoc/issues/41

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs