Problem cross-compiling version 3.5.1

Hello

I am currently trying to cross-compile gnuradio for ARM but I keep
getting build errors, or, to be more precise, linking errors related
to libgruel. I’m using GCC 4.6.1 and uClibc 0.9.32, this build log is
attached to this message.

If anyone has some idea about what I might be doing wrong, that would
be highly appreciated.

cheers

A lot of components you are building don’t seem to be necessary on
ARM, try configuring with " ./configure --disable-all-components
–enable-gnuradio-core " to just build the core and then enable only
the parts you need.

On Mon, Feb 20, 2012 at 17:29, Andrew D. [email protected]
wrote:

A lot of components you are building don’t seem to be necessary on
ARM, try configuring with " ./configure --disable-all-components
–enable-gnuradio-core " to just build the core and then enable only
the parts you need.

Thanks a lot for the advice. I’m somewhat new to gnuradio (as in, a
complete noob) and figured I’d just build things and figure out what I
need afterwards :slight_smile:

It seems though that gruel is required by gnuradio-core and if I
–disable-all-components, --enable-gnuradio-core and --enable-gruel I
get the same error again (new buildlog is attached).

Any other ideas?

On Mon, Feb 20, 2012 at 11:42 AM, Stefan O. [email protected] wrote:

Try to use cmake instead of configure to build GNU Radio. Check out the
“How do I install GNU Radio from source?” section on:
http://code.ettus.com/redmine/ettus/projects/usrpe1xx/wiki/FAQ.

Tom

On Mon, Feb 20, 2012 at 17:55, Tom R. [email protected] wrote:

Try to use cmake instead of configure to build GNU Radio. Check out the “How
do I install GNU Radio from source?” section
on:http://code.ettus.com/redmine/ettus/projects/usrpe1xx/wiki/FAQ.

Ok, thank you, I’ll try that.

cheers

Stefan O.
Communication and Distributed Systems
Institute of Computer Science and Applied Mathematics
University of Bern

Stefan -

The command listed in that FAQ relies on the use of a CMake toolchain
file,
which is distributed with GNU Radio.

A recent update (to CMake, possibly), seems to have broken use of the
toolchain file – all of the flags inside of it will get ignored.

Instead of passing the -DCMAKE_TOOLCHAIN_FILE flag, I would recommend
copying the flags out of the toolchain file, and put them on the CMake
line
manually. Depending on what version of CMake you have, this might be
unnecessary - but it is easy to workaround, and this way, you can be
sure.

Cheers,
Ben

On 02/20/2012 02:54 PM, Philip B. wrote:

copying the flags out of the toolchain file, and put them on the CMake line
manually. Depending on what version of CMake you have, this might be
unnecessary - but it is easy to workaround, and this way, you can be sure.

OK, it looks like cmake requires clubbing with a blunt instrument when
trying to use FLAGS in a toolchain file.

Can the people having issues try this fix and let me know if it works:

https://github.com/balister/GNU-Radio/commit/895d2373c2adcc4a0ce949f320d9d92ee672178a

Make that:

https://github.com/balister/GNU-Radio/commit/ffb564cf0361ebbb51d3715ab3cd9672d38f655c

Philip

On 02/20/2012 01:18 PM, Ben H. wrote:

manually. Depending on what version of CMake you have, this might be
unnecessary - but it is easy to workaround, and this way, you can be sure.

OK, it looks like cmake requires clubbing with a blunt instrument when
trying to use FLAGS in a toolchain file.

Can the people having issues try this fix and let me know if it works:

https://github.com/balister/GNU-Radio/commit/895d2373c2adcc4a0ce949f320d9d92ee672178a

It worked for me, but I did this against a repo on my desktop, so I hope
I avoided a typo :slight_smile:

Philip

On Mon, Feb 20, 2012 at 23:18, Philip B. [email protected]
wrote:

Instead of passing the -DCMAKE_TOOLCHAIN_FILE flag, I would recommend

Make that:

https://github.com/balister/GNU-Radio/commit/ffb564cf0361ebbb51d3715ab3cd9672d38f655c

Thanks a lot for all the advice so far. I am currently engaged in
combat, trying to get cmake to cooperate with pkg-config and find my
libraries (never used cmake before). I will report back when I get
some results or reach another point where I need help.

cheers

Stefan O.
Communication and Distributed Systems
Institute of Computer Science and Applied Mathematics
University of Bern

This fix appears to work for me compiling on the E100 itself.

Thanks a lot for all the advice so far. I am currently engaged in
combat, trying to get cmake to cooperate with pkg-config and find my
libraries (never used cmake before). I will report back when I get
some results or reach another point where I need help.

Ha, got it mostly working, thanks a lot to everyone. However, I seem
to have another problem now: python fails to load
_gnuradio_core_runtime.so (see below). Since I cross-compiled python
myself, I’m not sure whether this is actually a problem with gnuradio
or rather an issue with my python installation though.

Basically, what I get is the following:

from gnuradio import gr
Traceback (most recent call last):
File “”, line 1, in
File “/lib/python2.7/gnuradio/gr/init.py”, line 43, in
from gnuradio_core import *
File “/lib/python2.7/gnuradio/gr/gnuradio_core.py”, line 23, in

from gnuradio_core_runtime import *
File “/lib/python2.7/gnuradio/gr/gnuradio_core_runtime.py”, line 26,
in
_gnuradio_core_runtime = swig_import_helper()
File “/lib/python2.7/gnuradio/gr/gnuradio_core_runtime.py”, line 22,
in swig_import_helper
_mod = imp.load_module(’_gnuradio_core_runtime’, fp, pathname,
description)
ImportError: File not found

(if I try again, I get a segfault)

The file is there, of course, so the error message seems to be
“wrong”. If anyone has some input on this, that would be highly
appreciated.

cheers

Stefan O.
Communication and Distributed Systems
Institute of Computer Science and Applied Mathematics
University of Bern

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs