Problem building Ruby from sources

Hello,

I am having a problem building Ruby from sources (checked out latest
version with Subversion from repository). I tried it for Ubunty 8.04 and
Cygwin. In both cases I got an error while running make:

echo executable host ruby is required. use --with-baseruby option.;
false -Ks ./tool/insns2vm.rb --srcdir="." opt_sc.inc
executable host ruby is required. use --with-baseruby option.
make: *** [opt_sc.inc] Error 1

What does it mean?

Thank you,

Kurt

On Jul 2, 2008, at 08:06 AM, Kurt Usen wrote:

What does it mean?
You don’t have ruby installed, or it is not in your path.

If it is not in your path, use ./configure --with-baseruby (I think).

If it is not installed, try 1.8 before building 1.9.

Kurt Usen wrote:

What does it mean?

Thank you,

Kurt

Does it now need a running Ruby interpreter to build?

  1. you can check the recv msg if msg==nil
  2. maybe the send msg must add “\0” at end

“David Leal” [email protected]
写入邮件新闻:[email protected]

Eric H. wrote:

On Jul 2, 2008, at 08:06 AM, Kurt Usen wrote:

What does it mean?
You don’t have ruby installed, or it is not in your path.

If it is not in your path, use ./configure --with-baseruby (I think).

If it is not installed, try 1.8 before building 1.9.

I tried to install 1.8 (and tested that it is working) before build
(although it seemed to me strange enough not to be able to build Ruby
from scratch) and configure --with-baseruby with approximately the same
result…

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs