Problem after rails upgrade


#1

After upgrading rails (via gem update) I am getting a const_missing
error.

$ rails foo
/usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_support/dependencies.rb:200:in
const_missing': uninitialized constant Mapping (NameError) from /usr/lib/ruby/gems/1.8/gems/actionwebservice-0.9.3/lib/action_web_service/protocol/soap_protocol/marshaler.rb:7 from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:inrequire__’
from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
require' from /usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_support/dependencies.rb:214:inrequire’
from
/usr/lib/ruby/gems/1.8/gems/actionwebservice-0.9.3/lib/action_web_service/protocol/soap_protocol.rb:1
from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
require__' from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:inrequire’
from
/usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_support/dependencies.rb:214:in
require' ... 11 levels... from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:150:inactivate’
from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:38:in
require_gem_with_options' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:32:inrequire_gem’
from /usr/bin/rails:17

I’m running on FC3.

$ ruby -v
ruby 1.8.2 (2004-12-25) [i686-linux]

Any help greatly appreciated.

Cheers,
Jason


#2

On 11/17/05, Jason W. removed_email_address@domain.invalid wrote:

    from /usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_support/dependencies.rb:214:in
    from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:38:in

require_gem_with_options' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:32:inrequire_gem’
from /usr/bin/rails:17

I’m running on FC3.

$ ruby -v
ruby 1.8.2 (2004-12-25) [i686-linux]

To answer my own question, the new version must need a newer version
of ruby because after I upgraded to 1.8.3 rails started working again.

Cheers,
Jason