Problème serveur après installation de Active Scaffold

Bonjour à tous,

Voici mon problème:

Je voudrais changer le scaffolding actuel d’une application et passer
à ActiveScaffold, j’ai donc installé le plugin en suivant le pas-à -pas
indiqué sur le site d’ActiveScaffold.
Mon application fonctionnait jusque là sans problème mais il m’est
maintenant impossible de démarrer un serveur.

je pose le message que j’obtiens si cela peut servir.

=> Booting Mongrel
=> Rails 2.3.2 application starting on http://127.0.0.1:3004
/Applications/Locomotive2/Bundles/standardRailsMar2007.locobundle/i386/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/core_ext/module/aliasing.rb:33:in
alias_method': undefined method_pick_template’ for class
ActionView::Base' (NameError) from /Applications/Locomotive2/Bundles/standardRailsMar2007.locobundle/i386/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/core_ext/module/aliasing.rb:33:inalias_method_chain’
from /Users/great_bob_26/Documents/Aptana
Studio/abraracourcix/vendor/plugins/active_scaffold/lib/extensions/generic_view_paths.rb:46
from
/Applications/Locomotive2/Bundles/standardRailsMar2007.locobundle/i386/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /Applications/Locomotive2/Bundles/standardRailsMar2007.locobundle/i386/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/Applications/Locomotive2/Bundles/standardRailsMar2007.locobundle/i386/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:156:in
require' from /Applications/Locomotive2/Bundles/standardRailsMar2007.locobundle/i386/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:521:innew_constants_in’
from
/Applications/Locomotive2/Bundles/standardRailsMar2007.locobundle/i386/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:156:in
require' from /Users/great_bob_26/Documents/Aptana Studio/abraracourcix/vendor/plugins/active_scaffold/environment.rb:4 ... 27 levels... from /Applications/Locomotive2/Bundles/standardRailsMar2007.locobundle/i386/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from ./script/server:3
from -e:2:in `load’
from -e:2

Merci d’avance

Sébastien

Hello,

Quelle version de Active Scaffold as-tu utilisé ?
Il faut verifier la version supportée dans les differents
branches(rails-2.2) dans le GITHUB projet.

Stijn

2009/5/13 Sebastien P. [email protected]

/Applications/Locomotive2/Bundles/standardRailsMar2007.locobundle/i386/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/core_ext/module/aliasing.rb:33:in
/Applications/Locomotive2/Bundles/standardRailsMar2007.locobundle/i386/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in

from -e:2:in `load’
from -e:2

Merci d’avance

Sébastien

Posted via http://www.ruby-forum.com/.


Stijn Van Vreckem
http://www.xaop.com

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs