Problème rjs

Dans une de mes vues, j’ai crée un pseudo-lien avec le helper
link_to_function
qui lorsque l’on clique dessus fait apparaitre et/ou disparaitre
l’élément
qui le suit, en l’occurrence un

.
Détails de la fonction au sein de ma vue :
<%= link_to_function(rubrique.intitule, :class => “func_rubrique”) do
|page|
page.visual_effect :toggle_slide, “#{rubrique.id}”
end %>

Tout fonctionne parfaitement bien, excepté que lorsque la page est affichée,
tous les éléments sont visibles. Je souhaite que par défaut les éléments ne
soient pas affichés et qu’ils ne s’affichent que lorsque l’on clique sur
le
lien…

Si je joins un style=“display=none;” à mes éléments ils refusent tout
bonnement de s’afficher.

Quelqu’un aurai-til une piste ou un début de solution?
Merci.

2008/3/17 philippe caurier [email protected]:

Dans une de mes vues, j’ai crée un pseudo-lien avec le helper link_to_function
qui lorsque l’on clique dessus fait apparaitre et/ou disparaitre l’élément
qui le suit, en l’occurrence un

.
Détails de la fonction au sein de ma vue :
<%= link_to_function(rubrique.intitule, :class => “func_rubrique”) do |page|
page.visual_effect :toggle_slide, “#{rubrique.id}”
end %>

<%= link_to_function(rubrique.intitule, :class => “func_rubrique”,
:style => “display:none;”) do |page|
page.visual_effect :toggle_slide, “#{rubrique.id}”
end %>


Cyril M.
http://blog.shingara.fr

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs