(Previously working) AttributeError: 'module' object has no attribute

Hello all,

I was woking debuging an error that appear in my application, and in
order
to do that I intended to create a really simple block that basically
just
connected the output with the input as a bypass, and then I was going to
modify it with more features to understand the error. All the build and
installation (and testing) run just fine, but when I tried to run the
block
on gnr companion, appeared the common: “AttributeError: ‘module’ object
has
no attribute”

I found it strange, as I have already worked with gr_modtool, so just to
check if everything was in order, I went through the tutorial again
(wich
can be found here:
https://gnuradio.org/redmine/projects/gnuradio/wiki/OutOfTreeModules)
and
replicated the procedure for the block “square2_ff” (that I did when I
started witg gnuradio), trying to find if there was a step that I was
skipping. However, the same comes up:

Traceback (most recent call last):
File “/MY_WORKING_FOLDER/apps/top_block.py”, line 128, in
tb = top_block()
File “/MY_WORKING_FOLDER/apps/top_block.py”, line 97, in init
self.howto_square2_ff_0 = howto.square2_ff()
AttributeError: ‘module’ object has no attribute ‘square2_ff’

I’ve not been working with this a long time, so I’m quite uncertain of
what
I’m doing wrong, taking into account that I’ve done the same before and
it
worked.

If someone could give me some hints, I’d be very thankful.

Kind regards

Solved.

I needed just to type “sudo ldconfig” and afterwards it works like a
charm.

Thanks to all who read the problem.

On Thu, May 14, 2015 at 10:02 PM, Nicolas Cuervo B. <

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs