Preventing RSS/Atom Fragment Caching for FeedBurner Integrat

I recently tried Ben Curren’s approach to redirecting
feed requests to FeedBurner:

His approach works great until Feedburner accesses my
feed. Feedburner’s request is handled by Typo, placing
the feed into the fragment cache (apparently).

I say apparently, because every feed accessed after
FeedBurner’s request results in Typo handling the
request. When I check my log, I see something like

Processing XmlController#feed (for XXX.XXX.XXX.XXX at
2007-07-29 15:49:56) [GET]
Parameters: {“format”=>“rss20”, “action”=>“feed”,
“type”=>“feed”, “controller”=>“xml”}
Filter chain halted as
did not yield.
Completed in 0.00134 (748 reqs/sec) | Rendering:
0.00010 (7%) | DB: 0.00000 (0%) | 304 Not Modified

But when I clear the fragment cache, RSS/Atom requests
are re-directed to FeedBurner - until the next time
FeedBurner asks for my feed.

So… how can I disable caching of specific types of
content in Typo? What would be an alternative approach
to the one I’m trying?