Premature end of script headers


#1

Hi.

We install ruby, rail, rubygems, rails, mod_fastcgi and fastCGI nad we
get from this URL http://bobcares.com/article38.html ans everything
install with no errors, but when we try to run “test” we get this:

Error from apache error_log:

Premature end of script headers:
/home/user/public_html/rails/dispatch.cgi
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:46:in `require’: no such
file to load – rubygems/rubygems_version.rb (LoadError)
from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:46
from ./…/config/boot.rb:18
from ./…/config/environment.rb:11
from dispatch.cgi:3
[Fri Apr 14 17:27:40 2006] [error] Premature end of script headers:
/home/user/public_html/rails/dispatch.cgi


dispatch.cgi

#!/usr/local/bin/ruby

require File.dirname(FILE) + “/…/config/environment” unless
defined?(RAILS_ROOT)

require “dispatcher”

ADDITIONAL_LOAD_PATHS.reverse.each { |dir| $:.unshift(dir) if
File.directory?(dir) } if defined?(Apache::RubyRun)
Dispatcher.dispatch


.htaccess

Options +FollowSymLinks +ExecCGI


We dont know what is wrong. Anyone got idea or any fix for that ?

Thank you.

dbMG