Premature end of script headers error using Rails 2.3.1 and Passenger 2.1.1


#1

I’m getting an HTTP 500 Internal Server Error using the latest beta of
Rails (2.3.1 aka 2.3 RC2) and Passenger (2.1.1) beta under Ubuntu
Intrepid (8.1).

I’ve put the Passenger configuration files into two separate files
under mods-available and I’ve created symbolic links from mods-
enabled. The default way of the Apache configuration under Ubuntu 8.1,
just like all other modules.
I am getting ‘Premature end of script headers: rails, referer: …’
errors and I have no idea why this happens. It never happened before
when I was using 8.04 (Hardy release)

Here’s my configuration:

/etc/apache2# cat apache2.conf | grep -i mods-enabled
Include /etc/apache2/mods-enabled/.load
Include /etc/apache2/mods-enabled/
.conf

/etc/apache2/mods-enabled# ls -la | grep passenger
lrwxrwxrwx 1 root root 32 Mar 4 22:19 passenger.conf -> …/mods-
available/passenger.conf
lrwxrwxrwx 1 root root 32 Mar 4 22:19 passenger.load -> …/mods-
available/passenger.load

/etc/apache2/mods-enabled# cat passenger.load
LoadModule passenger_module /opt/rubyenterprise/lib/ruby/gems/1.8/gems/
passenger-2.1.1/ext/apache2/mod_passenger.so

/etc/apache2/mods-enabled# cat passenger.conf

PassengerRoot /opt/rubyenterprise/lib/ruby/gems/1.8/gems/
passenger-2.1.1
PassengerRuby /opt/rubyenterprise/bin/ruby

PassengerDefaultUser www-data

I’ve commented out the PassengerDefaultUser directive, since the whole
Apache process is running under the www-data user so it doesn’t seem
to be necessary. However, now I’m getting the server error above.
I don’t know if this is a problem with the Rails application itself
(blank newly created, v 2.3.1 - aka 2.3 RC2) Rails or with Passenger
2.1.1 beta.

Any thoughts?
Cheers,
Attila


#2

OK, i’ve put the configuration files into pastie since Google broke it
into more lines, it think this is more readable now:
http://pastie.org/411007


#3

Attila Györffy wrote:

I am getting ‘Premature end of script headers: rails, referer: …’
errors and I have no idea why this happens.

Is this the exact error message?


Phusion | The Computer Science Company

Web: http://www.phusion.nl/
E-mail: removed_email_address@domain.invalid
Chamber of commerce no: 08173483 (The Netherlands)