Pregunta sobre libreria


#1

Saludos compañeros de la lista:

Por que me sale esto en mis aplicaciones???

Uso Debian lenny y rails 2.1.0

WARNING: You’re using the Ruby-based MySQL library that ships with
Rails. This library is not suited for production. Please install the
C-based MySQL library instead (gem install mysql).


Visite nuestra web en Internet
http://www.ispvc.rimed.cu
“50 Años de Educación en
Revolución”

Este mensaje ha sido analizado por MailScanner
en busca de virus y otros contenidos peligrosos,
y se considera que está limpio.


#2

te dice que intales la gema mysql

sudo gem install mysql

la que estas usando no esta hecha para producción

Saludos

Atte.
Miguel Michelson Martinez

www.artenlinea.cl

On Thu, Nov 6, 2008 at 5:34 PM, [Webmaster]_Yoel_Villarreal <


#3

Si… bueno… gracias por tu pronta respuesta… a la verdad es que esa
parte si la entendi… la recomendacion que me da… pero me referia a
el por qué esa implementacion no es libre para produccion (razon
politica, estrategia de mercado, licencia,)…

De todas formas es solo un warning…

Otra cosa es que dependo mucho de un repositorio de software debido a
restricciones en el ancho de banda, no me gusta ir a buscar cosas a
internet. Ya veo que no puedo prescindir del todo 100% del sistema de
gemas.

Gracias nuevamente.


Visite nuestra web en Internet
http://www.ispvc.rimed.cu
“50 Años de Educación en
Revolución”

Este mensaje ha sido analizado por MailScanner
en busca de virus y otros contenidos peligrosos,
y se considera que está limpio.


#4

En Rails 2.2 la libreria mysql ya no vendra incluida y por tanto se
tendra que instalar la gema.


#5

Buena esa que me dices ahora Francesc… a ver como hago para mirrorear
gemas entonces.


Visite nuestra web en Internet
http://www.ispvc.rimed.cu
“50 Años de Educación en
Revolución”


#6

[Webmaster]_Yoel_Villarreal
escribió:> Si… bueno… gracias por tu pronta respuesta… a la verdad es que esa

parte si la entendi… la recomendacion que me da… pero me referia a
el por qué esa implementacion no es libre para produccion (razon
politica, estrategia de mercado, licencia,)…

De todas formas es solo un warning…

Se refiere a que la gema es recomendable para produccion, cuestion de
rendimiento (c vs ruby).
No tienes ningun problema en desarrollo, que yo sepa.


#7

Y un sudo gem install mysql no te sirve?

On 06/11/2008, at 22:37, “[Webmaster]_Yoel_Villarreal”
<removed_email_address@domain.invalid


#8

La cuestion es que acceder e instalar con gem es mas lento comparado
con aptitude en mi repo local de Debian, y no es capricho lo de la
velocidad y el ancho de banda… es que estoy en un pais donde no llega
la Fibra Optica (producto del bloqueo).


Visite nuestra web en Internet
http://www.ispvc.rimed.cu
“50 Años de Educación en
Revolución”


#9

Hmmm… interesante esto, mira Francesc:

net:~# aptitude search libdbd-mysql-ruby
p libdbd-mysql-ruby - Ruby/DBI driver for
MySQL
p libdbd-mysql-ruby1.8 - Ruby/DBI MySQL driver for Ruby 1.8

Creo que por aqui solucionare mientras tanto.


Visite nuestra web en Internet
http://www.ispvc.rimed.cu
“50 Años de Educación en
Revolución”