Pre-release note for the christmas release

Hi,

I think I have almost done the basic design & implementation work for
1.9.0, which is going to be released today.

A few notes before the release:

  • The relase version will be 1.9.0, not 1.9.1 as we have
    announced before. This denotes the fact it is not as
    stable as we expected. But the all incompatible changes
    are done already.

  • There already are some known bugs. The relase note will
    include the number of failed tests from standard “make test”
    and “make test-all”.

  • The release will be planed to be 3:00pm Japanese Standard Time,
    which is 9 hours ahead of UTC. It may be delayed as we have
    suffered in the previous releases. We try our best not to be too
    late.

  • THE 1.9 IS INCOMPATIBLE. YOUR APPLICATION MAY NOT WORK AS IT IS.
    The porting know-how (or porting tools maybe) will not provided as
    of the first release.

Thank you for your kind cooperation.

          matz.

Yukihiro M. wrote:

are done already.

Can we expect no more features or incompatible changes between 1.9.0 and
whatever becomes 1.9.1? In other words, would it be safe for us on JRuby
to start implementing our 1.9 features based on what’s released as
1.9.0?

Also, does this officially mean that the release is considered
“unstable”?

  • Charlie

Hi,

In message “Re: pre-release note for the christmas release.”
on Tue, 25 Dec 2007 05:12:15 +0900, Charles Oliver N.
[email protected] writes:

|Can we expect no more features or incompatible changes between 1.9.0 and
|whatever becomes 1.9.1? In other words, would it be safe for us on JRuby
|to start implementing our 1.9 features based on what’s released as 1.9.0?

Yes, basically, except for the possibility that we have to fix
something we have designed severely wrong, if any.

|Also, does this officially mean that the release is considered “unstable”?

I don’t consider it “production level”. Bugs may remained. But we
try making it stable.

          matz.

On Tue, Dec 25, 2007 at 02:32:54AM +0900, Yukihiro M. wrote:

are done already.
  • THE 1.9 IS INCOMPATIBLE. YOUR APPLICATION MAY NOT WORK AS IT IS.
    The porting know-how (or porting tools maybe) will not provided as
    of the first release.

Thank you for your kind cooperation.

          matz.

Thanks Matz, You’re my hero. Have a merry Christmas :slight_smile:

  • Tom

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs