Post not showing up on home page


#1

First of all I’m pretty new to the typo blogging platform, so figure
that I have no idea how typo works. I’ve managed to get it setup with
thin being proxied through a Cherokee web server but I do not know the
ins-and-outs of typo itself.

Anyway, I wrote my first article today, created a new category to
place it in and published it. I can access and read the article by
browsing to the category view but the article doesn’t show up on the
blog’s home page. I have no idea what could be causing this. I thought
it would just show up. I know there was a default article that came
with the blogging platform after installation but I deleted that
article. The article I wrote today was created as a new article.

Any help on resolving this is appreciated.


#2

Le 21 juil. 2011 21:25, Jonathan M. Polom a crit :

with the blogging platform after installation but I deleted that
article. The article I wrote today was created as a new article.

Any help on resolving this is appreciated.

Hello Jon,

First thank you for using our carefully crafted blogging engine, we’re
always happy to hear from a new user.

Please, can you login into the admin -> settings -> cache, remove all
cache, then go to your blog homepage and hit ctrl+f5 to be sure you’re
not displaying a cached page.

If this doesn’t work, can you:
tell me which typo version and which theme you’re using.
send me the content of log/production.log when you try to load the
homepage

Best regards,
Frederic


Frdric de Villamil
“What’s mine is mine. What’s yours is still unsetteled” Go player
proverb
removed_email_address@domain.invalid tel: +33 (0)6 62 19 1337
http://t37.net Typo : http://typosphere.org


#3

Frederic: Thanks for getting back with me so quickly. I have to say
typo has awesome support if the main dev responds within two hours to
a mailing list question. Anyway, I just checked the main page from my
browser on a different machine than that from which I was experiencing
problems on and I see the article now. It must have been a cached
page. I figured since it looked like it was loaded via ajax cache
wouldn’t have been an issue.

As for the cache clearing step you suggested though, were you
referring to clearing browser cache or some kind of cache for the typo
application? I looked in the typo admin panel under settings and found
no such mention of “cache.” Just curious for the future. I assume you
mean browser cache.

Thanks a lot.

On Thu, Jul 21, 2011 at 3:42 PM, Frederic de Villamil


#4

Le 21 juil. 2011 23:29, Jonathan M. Polom a crit :

application? I looked in the typo admin panel under settings and found
no such mention of “cache.” Just curious for the future. I assume you
mean browser cache.

Thanks a lot.

Hi Jonathan,

You’re lucky: I’m in vacation and the weather has just been horrible for
a week, which explains why I’ve been so fast relying.

This aside, depending on which Typo version you’re running, you may find
the link to the cache clearing page at http:///admin/cache

Best regards,
Frdric

Frdric de Villamil
“What’s mine is mine. What’s yours is still unsetteled” Go player
proverb
removed_email_address@domain.invalid tel: +33 (0)6 62 19 1337
http://t37.net Typo : http://typosphere.org


#5

I’m running 6.0.4 and I tried that URL and typo claimed it couldn’t find
the
page. Another question if you don’t mind; is it possible to enable SSL
for
the admin section of the blog? I could obviously enable URL rewriting in
my
web server configuration but I’d prefer to use a method at the
application
level.

Thanks for the help.

On Fri, Jul 22, 2011 at 8:02 AM, Frederic de Villamil <


#6

Le 22 juil. 2011 18:41, Jonathan M. Polom a crit :

I’m running 6.0.4 and I tried that URL and typo claimed it couldn’t find the
page. Another question if you don’t mind; is it possible to enable SSL for the
admin section of the blog? I could obviously enable URL rewriting in my web server
configuration but I’d prefer to use a method at the application level.

Thanks for the help.

I see, this feature was added in 6.0.5 which explains why you can’t see
it.

Enabling SSL for the admin is unfortunately something you’ll have to do
with a redirection to your WebServer. However, if someone want to push a
patch to enable it on the application side, I’m OK to consider it :slight_smile:

Have a nice day,
Frederic


Frdric de Villamil
“What’s mine is mine. What’s yours is still unsetteled” Go player
proverb
removed_email_address@domain.invalid tel: +33 (0)6 62 19 1337
http://t37.net Typo : http://typosphere.org