Point Me to Mocha 0.9.3


#1

I can’t seem to find a copy of Mocha 0.9.3, gem or otherwise.

A recent patch to ActiveSupport requires Mocha 0.9.3 support.[1] The
Mocha home page advertises 0.9.2.[2] The current tree at github[3]
builds into 0.9.2.[4] So–erm–where is this mysterious 0.9.3 release?

I know I can make it work by building mocha head, changing the
requirements in the tests to 0.9.2. But that defeats the point of
automated tests, no?

http://josephholsten.com

[1]


[2] http://mocha.rubyforge.org/
[3]
http://github.com/floehopper/mocha/tree/990a1622c962761b54152a4eea95434b47f29817
[4]
http://github.com/floehopper/mocha/tree/d53b6ca013d384fee70d6362e50c83200e4e46c7/Rakefile


#2

2008/11/25 http://josephholsten.com removed_email_address@domain.invalid

Scary - ActiveSupport is so bleeding edge that it’s relying on a
“future”
release of Mocha!

I’ll do a release now.


James.
http://blog.floehopper.org


#3

I’ve decided to hold fire until I find out what jeremy was expecting in
this
commit [1].

James.
http://blog.floehopper.org

[1]
http://github.com/rails/rails/commit/e931012287df0bca83cae04d95c2e0835ae08758


#4

No worries, I got the patch from Jeremy
http://josephholsten.com