PLZ HELP - ROR on Redhat Linux :: Problem with backgroundrb

Hi,

I have successfully crossed all the hurdles to install Ruby on rails on
a redhat 5 Linux based system.

But the last and the biggest hurdle i am facing at this moment is
installing backgrounrb :frowning:

I followed all the steps from the http://backgroundrb.rubyforge.org/

  1. sudo gem install chronic packet

  2. script/plugin install svn://rubyforge.org/var/svn/backgroundrb
    [IMP:::: I had to drop from the step 2 and 3 from the
    http://backgroundrb.rubyforge.org/ as the deviavu.com system is no
    longer responding to me and and the git/piston are not supported on my
    system; dono what exactly are they :frowning: ]

  3. rake backgroundrb:setup
    — Successfully created the database.yml under config dir and
    worker dir under lib.

  4. rake db:migrate

  5. When started the backgroundrb, I got the following error:
    =======================================================================

./script/backgroundrb/start

/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.4/lib/active_support/depreca
tion.rb:17: private method warn' called for nil:NilClass (NoMethodError) from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.4/lib/active_su pport/deprecation.rb:24:incall’
from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.4/lib/active_su
pport/deprecation.rb:24:in warn' from /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_rec ord/connection_adapters/abstract/connection_specification.rb:98:inallow_concur
rency=’
from ./script/backgroundrb/start:67

MY GEM ENV’s


RubyGems Environment:

  • RUBYGEMS VERSION: 1.3.4
  • RUBY VERSION: 1.8.8 (2009-10-09 patchlevel -1) [x86_64-linux]
  • INSTALLATION DIRECTORY: /usr/local/lib/ruby/gems/1.8
  • RUBY EXECUTABLE: /usr/local/bin/ruby
  • EXECUTABLE DIRECTORY: /usr/local/bin
  • RUBYGEMS PLATFORMS:
    • ruby
    • x86_64-linux
  • GEM PATHS:
    • /usr/local/lib/ruby/gems/1.8
    • /root/.gem/ruby/1.8
  • GEM CONFIGURATION:
    • :update_sources => true
    • :verbose => true
    • :benchmark => false
    • :backtrace => false
    • :bulk_threshold => 1000
  • REMOTE SOURCES:

PLS HELP ME TO SOLVE THIS ISSUE

before blaming backgroundrb, make sure your ruby application works in
production mode & development mode. Then try to start backgroundrb;
it tries load an instance of your rails application and the errors you
see might be due to your application.

On Oct 15, 6:40 am, Sapna R. [email protected]

Mukund wrote:

before blaming backgroundrb, make sure your ruby application works in
production mode & development mode. Then try to start backgroundrb;
it tries load an instance of your rails application and the errors you
see might be due to your application.

On Oct 15, 6:40�am, Sapna R. [email protected]

Well, my ruby application works pretty well, it just the background
daemon killing my time… :frowning:

Again, backgroundrb is now on Github. It clearly states on the
website to use git to get the latest version.

git clone git://github.com/gnufied/backgroundrb.git (into your vendor/
plugins directory)

To install git on Redhat? (do you mean fedora?). You can try

$ sudo yum install git

If that doesn’t work for you, download the source for Git from the web
and build it locally. It isn’t that hard to do on Linux.

Mukund wrote:

Again, backgroundrb is now on Github. It clearly states on the
website to use git to get the latest version.

git clone git://github.com/gnufied/backgroundrb.git (into your vendor/
plugins directory)

To install git on Redhat? (do you mean fedora?). You can try

$ sudo yum install git

If that doesn’t work for you, download the source for Git from the web
and build it locally. It isn’t that hard to do on Linux.

Again after the whole day google search I just figured that out.
Copied the package and the backgroundrb under vendor/plugins on my
redhat server.

Now the real fun started…
the git-hub points to the latest gem, but the one mentioned in the
website is 0.1.6gem.
Again after invading the whole google pages, I was able to get the 0.1.6
gem package and then everything went well.

Now when I do the ./script/backgrounrb start, I have couple of issue
I. I don’t see any logger lessages.
II. Also, if I copy my worker file under lib/workers the backgroundrb
fails by complaing about the dependencies :frowning:

Snapshot from the background_server*.log

/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original _require': no such file to load -- log_worker (LoadError) from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/usr/local/lib/ruby/gems/1.8/gems/packet-0.1.15/bin/packet_worker_r
unner:35:in load_worker' from /usr/local/lib/ruby/gems/1.8/gems/packet-0.1.15/bin/packet_worker_r unner:26:ininitialize’
from
/usr/local/lib/ruby/gems/1.8/gems/packet-0.1.15/bin/packet_worker_r
unner:47:in `new’
from
/usr/local/lib/ruby/gems/1.8/gems/packet-0.1.15/bin/packet_worker_r
unner:47

Sapna R. wrote:

Mukund wrote:

Again, backgroundrb is now on Github. It clearly states on the
website to use git to get the latest version.

git clone git://github.com/gnufied/backgroundrb.git (into your vendor/
plugins directory)

To install git on Redhat? (do you mean fedora?). You can try

$ sudo yum install git

If that doesn’t work for you, download the source for Git from the web
and build it locally. It isn’t that hard to do on Linux.

Again after the whole day google search I just figured that out.
Copied the package and the backgroundrb under vendor/plugins on my
redhat server.

Now the real fun started…
the git-hub points to the latest gem, but the one mentioned in the
website is 0.1.6gem.
Again after invading the whole google pages, I was able to get the 0.1.6
gem package and then everything went well.

Now when I do the ./script/backgrounrb start, I have couple of issue
I. I don’t see any logger lessages.
II. Also, if I copy my worker file under lib/workers the backgroundrb
fails by complaing about the dependencies :frowning:

Snapshot from the background_server*.log

By the way thanks a lot Mukund for your valuable response, I wish I had
these details earlier today…

Can you please help me to get the above issue resolved?

On Oct 15, 1:48 am, Sapna R. [email protected]
wrote:

pport/deprecation.rb:24:in warn' from /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_rec ord/connection_adapters/abstract/connection_specification.rb:98:inallow_concur
rency=’
from ./script/backgroundrb/start:67

It looks like the root cause is that the version of backgroundrb you
are trying to use is trying to access a deprecated setting in
activerecord, and the deprecation warning mechanism is blowing up (I’d
guess because the rails logger isn’t available). In this particular
case that setting is now a setting with no effect so you could just
comment it out from backgroundrb/start, however unless you know what
you’re doing I’d really recommend that you get the latest version, as
others have advised.

=======================================================================

MY GEM ENV’s


RubyGems Environment:

  • RUBYGEMS VERSION: 1.3.4
  • RUBY VERSION: 1.8.8 (2009-10-09 patchlevel -1) [x86_64-linux]

Probably not relevant here, but I don’t think that ruby 1.8.8 is
actually out yet.

Fred

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs