Plugin not found: ["acts_as_list"]


#1

I am trying to install acts_as_list in a rails 2.2.2 project but when I
try the following: ruby script/plugin install acts_as_list

I get: Plugin not found: [“acts_as_list”]

I had to download the acts_as_list plugin from the github because it
isn’t included in Rails 2.2.2.

The files are in my vendor/plugins/acts_as_list folder so I have:

lib/active_record/acts/list.rb
README
test/list_test.rb
init.rb

What am I doing wrong here?

TIA


#2

if the plugin is already installed in vendor/plugins there is no
reason to install it with script/plugin.

On Jan 4, 6:48 pm, Jason N. removed_email_address@domain.invalid


#3

Andrew B. wrote:

if the plugin is already installed in vendor/plugins there is no
reason to install it with script/plugin.

On Jan 4, 6:48�pm, Jason N. removed_email_address@domain.invalid

That is what I was thinking, but I was getting in errors in the console
when I was trying to create new objects in the database giving me an
error involving acts_as_list.

I shut down my computer and when I came back it worked. I tried
stopping my server and closed all terminal sessions and still didn’t
work until I rebooted my computer…now it works.

PICNIC = problem in chair not in computer!


#4

The way to install it from scratch is (on Win):

  • cd into the rails_app/vendor/plugins dir
  • git clone git://github.com/rails/acts_as_list.git