Please try new master branch

I just merged in a change to git that tries to fix the parallel build
problem without calling ‘sync.’ If you are one of our users who likes to
work off git and builds in parallel (‘make -jN’ for N>1), we were having
an
issue of files not being ready while they were being parsed. See issue
#478
on gnuradio.org for more details. The current version in git works for
me
on multiple machines, but I’d like more feedback if it’s failing for
anyone.

Thanks.

Is this for autotools or CMake? The CMake build (new master) works
using “-j2” for me (OSX 10.6.8, XCode 3.2.3; gcc 4.2.1); haven’t tried
the autotools build because it has issues & I’ve mostly transitioned to
using CMake instead. - MLD

Using Marcus’ build-gnuradio just now it worked great. GRC runs and
talks to my USRP.

Command:
./build_gnuradio -j5

gnuradio commit:
d2ff8e3438c83876bdcc587a76b40c7a4281d3c6

uhd commit:
287958ba36072f699090aa61ad2b6bbee6846d66

This was run at approximately 20 Jan 2012 19:00:00 UTC

On 01/20/2012 10:40 AM, Tom R. wrote:


Tom
Single-threaded build failing at the moment:

Linking CXX shared library libgruel-3.5.2git.so
cd /home/mleech/gnuradio/build/gruel/src/lib && /usr/bin/cmake -E
cmake_link_script CMakeFiles/gruel.dir/link.txt --verbose=1
/usr/lib64/ccache/c++ -fPIC -O3 -DNDEBUG -shared
-Wl,-soname,libgruel-3.5.2git.so.0.0.0 -o libgruel-3.5.2git.so.0.0.0
CMakeFiles/gruel.dir/msg/msg_accepter.cc.o
CMakeFiles/gruel.dir/msg/msg_accepter_msgq.cc.o
CMakeFiles/gruel.dir/msg/msg_queue.cc.o
CMakeFiles/gruel.dir/pmt/pmt_unv.cc.o CMakeFiles/gruel.dir/pmt/pmt.cc.o
CMakeFiles/gruel.dir/pmt/pmt_io.cc.o
CMakeFiles/gruel.dir/pmt/pmt_pool.cc.o
CMakeFiles/gruel.dir/pmt/pmt_serialize.cc.o
CMakeFiles/gruel.dir/realtime.cc.o CMakeFiles/gruel.dir/sys_pri.cc.o
CMakeFiles/gruel.dir/thread_body_wrapper.cc.o
CMakeFiles/gruel.dir/thread_group.cc.o -lboost_date_time-mt
-lboost_program_options-mt -lboost_filesystem-mt -lboost_system-mt
-lboost_thread-mt
cd /home/mleech/gnuradio/build/gruel/src/lib && /usr/bin/cmake -E
cmake_symlink_library libgruel-3.5.2git.so.0.0.0
libgruel-3.5.2git.so.0.0.0 libgruel-3.5.2git.so
cd /home/mleech/gnuradio/build/gruel/src/lib && /usr/bin/cmake -E
create_symlink libgruel-3.5.2git.so.0.0.0
/home/mleech/gnuradio/build/gruel/src/lib/libgruel.so
make[2]: *** [gruel/src/lib/libgruel-3.5.2git.so.0.0.0] Error 1
make[2]: Leaving directory /home/mleech/gnuradio/build' make[1]: *** [gruel/src/lib/CMakeFiles/gruel.dir/all] Error 2 make[1]: Leaving directory/home/mleech/gnuradio/build’

This is with a Cmake build, on Fedora 14-x86_64

This is with a make clean; make

On 01/20/2012 07:29 PM, Marcus D. Leech wrote:

Following up on my own post here. A complete, fresh, check-out along
with a virgin ‘build’ directory caused it to be able to build
single-thread.
About to test multi-thread.

Following up again.

make clean; make -j4

On the previously-fresh checkout of Gnu Radio git master worked just
fine.

It’s conceivable that I left some detritus around from a previous
late-nite fuzzy-brained build or something. So a clean “git clone”
seems
to have produced a working build both with a single-threaded make,
and a make -j4. Yay.

(This is with Cmake. I haven’t used autotools build in a few weeks).

Together with autotools

make -j5

works.

Only gr-noaa does not build.

No rules to make gnuradio-noaa.pc .

To fix this problem, see the following diff

*** grc_gr_noaa.m4 2012-01-21 11:35:51.000000000 +0100
— grc_gr_noaa.m4.new 2012-01-21 11:35:37.000000000 +0100


*** 27,32 ****
— 27,33 ----

   AC_CONFIG_FILES([\
       gr-noaa/Makefile \
  • gr-noaa/gnuradio-noaa.pc \
     gr-noaa/apps/Makefile \
     gr-noaa/grc/Makefile \
     gr-noaa/lib/Makefile \
    

Volker

On 01/20/2012 06:15 PM, Marcus D. Leech wrote:

CMakeFiles/gruel.dir/msg/msg_accepter_msgq.cc.o
cd /home/mleech/gnuradio/build/gruel/src/lib && /usr/bin/cmake -E

Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org


Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
Following up on my own post here. A complete, fresh, check-out along
with a virgin ‘build’ directory caused it to be able to build
single-thread.
About to test multi-thread.

On Fri, Jan 20, 2012 at 11:21 AM, Michael D. [email protected]
wrote:

Is this for autotools or CMake? The CMake build (new master) works using
“-j2” for me (OSX 10.6.8, XCode 3.2.3; gcc 4.2.1); haven’t tried the
autotools build because it has issues & I’ve mostly transitioned to using
CMake instead. - MLD

It was specifically for the cmake builds. We didn’t enable the swig docs
in
autotools, so the bug only affected cmake.

Thanks for checking.

Tom

On Sat, Jan 21, 2012 at 5:40 AM, Volker S. [email protected] wrote:

To fix this problem, see the following diff
gr-noaa/apps/Makefile
gr-noaa/grc/Makefile
gr-noaa/lib/Makefile \

Volker

Thanks, Volker. I just pushed a fix for that.

Tom

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs