Permissions error when using Rick Olson's deploy_edge

Hi all - I tried the question below on the Rails Deployment forum, but
that forum seems to get very little traffic. Perhaps someone here can
offer some help:

I’ve been trying to get my app running on Rails edge per the
instructions on Mike C.'s blog
(, specifically per the last
section of that post.

I’ve got edge working fine on my local machine, and I’ve set svn to
ignore vendor/rails so that it doesn’t get exported every time I
redeploy to the production machine. I’m using Rick O.'s deploy_edge
rake task
called from an after_update_code cap hook. The task gets called fine -
but I run into the following error:

** [out ::] (in /var/www/apps/theapp/releases/20070822204440)
** [out ::] setting up rails trunk
** [out ::] mkdir -p …/…/shared/rails/trunk/railties
** [out ::] rake aborted!
** [out ::] Permission denied - …/…/shared/rails

I ssh’d in to check the permissions:
deploy@server:/var/www/apps/theapp$ ls -l
total 12
lrwxrwxrwx 1 deploy users 44 Aug 21 17:32 current →
drwxrwxr-x 75 deploy deploy 4096 Aug 22 20:46 releases
-rw-rw-rw- 1 deploy users 3273 Aug 22 20:46 revisions.log
drwxrwxr-x 6 root app_theapp 4096 Jun 11 21:20 shared

I’ve run into permissions problems with other apps in the past, and
whenever I try to fix them I end up royally screwing things up - so I
was wondering if anyone has run into this problem before and could
suggest a fix.

I’m also open to any suggestions on other ways to automatically deploy
to edge without exporting the entire rails source on each deploy.


  • Mark