Permission to access /usr/local

Hi all,

I use “sudo make install” to setup the gnuradio in ubuntu9.10. The
problem
is that I have to use “sudo” every time to run an
application(./benchmark_tx.py). Without running as a super user, I will
receive the error msg like could not load the firmware to FPGA through
USB,
permission denied. I searched previous threads that it was recommended
to
use “chmod g+s” under /usr/local/share to get the permission to write
this
directory. However, I was wondering if there is any other way to run
applications with USRP without stating as “sudo” everytime? Thank you!

Best,

Milo

is any other way to run applications with USRP without stating as
“sudo” everytime? Thank you!
I don’t know if it’s the recommended way, but you should be able to use
the “–prefix”- flag with the configuration- script.
Next time you install, try something like:
bootstrap
configure --prefix=~/gnuradio_install_path
make
make install

This way you will install gnuradio into “~/gnuradio_install_path/” (I
think). Thats the “usual” behavior of configure, but I’d check
“configure --help” before I do anything if I were you.

//Mattias

On Thu, Jan 21, 2010 at 4:33 AM, Mattias K. [email protected] wrote:

However, I was wondering if there
is any other way to run applications with USRP without stating as
“sudo” everytime? Thank you!

You will need to give yourself permission to access the device (using
group permissions)

http://gnuradio.org/redmine/wiki/1/UdevConfig will give instructions.

Jason

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs