Paypal gem and OpenSSL


#1

I have just installed the Paypal gem (v 1.0.1) along with the money gem
(v. 1.5.9) and am getting the “uninitialized constant Paypal” error
message
after adding the line “include Paypal::Helpers” to my
application_helper.rb
file:

module ApplicationHelper
include Paypal::Helpers
end

The Paypal readme says:
“uninitalized constant Paypal - Make sure your ruby has openssl support”

I am running Mac OS 10.4.3 and it has OpenSSL 0.9.7g installed. I have
Rails
0.14.3 and Ruby 1.8.2.

In an attempt to test whether I have OpenSSL support I tried the
following:

module ApplicationHelper
#include Paypal::Helpers
include OpenSSL
end

and it didn’t raise any errors.

Can anyone give me some advice on troubleshooting this? Is OpenSSL
likely the
problem here or might it be something else?


#2

Ana Nelson <nelson.ana@…> writes:

I have just installed the Paypal gem (v 1.0.1) along with the money gem
(v. 1.5.9) and am getting the “uninitialized constant Paypal” error message
after adding the line “include Paypal::Helpers” to my application_helper.rb
file:

module ApplicationHelper
include Paypal::Helpers
end

This is working now:

require ‘paypal’

module ApplicationHelper
include Paypal::Helpers
end