Payment gem, server anomolies

so i have the payment gem working perfectly in our app, running locally
on my system.

uploaded a copy of the app file structure to our server (a rimu rhel3),
but now the payment gem is unresponsive. it throws exceptions with no
error message.

i’m looking for a suggestion how to debug this.

running updated gems and versions on both systems. they seem identical,
unless i’m missing something tricky?

any guesses would be appreciated. cheers!

so given the example code:

def pay_test
transaction = Payment::AuthorizeNet.new (
:login => ‘cnpdev4206’,
:password => ‘authnet001’,
:amount => ‘5.00’,
:card_number => ‘4012888818888’,
:expiration => ‘03/10’
)

  begin
    transaction.submit
    flash[:notice] = "ok: #{transaction.authorization}"
  rescue
    flash[:notice] = "oops: #{transaction.error_message}"
  end

end

with the ‘require’ at the top of course.

after messing with the payment code, i think the exception isn’t being
thrown by payment, but by ruby, like payment gem not found, so the
variable is bunk, although the ‘AuthorizeNet.new’ still checks out ok?

‘gem list’ shows payment loud and clear.

any ideas?

getting a lead here:

NoMethodError in PagesController#pay_test

undefined method `use_ssl=’ for #<Net::HTTP test.authorize.net:443
open=false>

isn’t Net:HTTP a base class?

Did you ever figure out what happened here? I have the same problem
with the same server. Works locally on my machine but when I upload to
the server, it breaks. I tried installing ruby 1.8.2 and openssl but
the same error message comes up.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs