Patch install error

Hello.

Wonder if you could help me please. I’ve installed nginx 0.7.59 or
0.7.62 and i wish to apply the patch by witch I can do ssl_crl
verifications.But i get the following error:

cc1: warnings being treated as errors
src/event/ngx_event_openssl.c: In function ângx_ssl_crlâ:
src/event/ngx_event_openssl.c:294: warning: pointer targets in passing
argument 3 of âX509_LOOKUP_ctrlâ differ in signedness
make[1]: *** Error 1
make[1]: Leaving directory `/tmp/nginx-0.7.59’
make: *** Error 2

These are my install steps:

patch -p1 < …/0002-Add-SSL-CRL-verifications.patch
./configure --sbin-path=/usr/local/sbin --with-http_ssl_module
make
…and then i get the error.

This happens with any of the versions. Can you please tell me if I’m
doing something wrong or is it something I’ve missed ?

Thank you in advance.

Bogdan Zglobiu

P.S - I’ running CentOS 5.3 on a Pentium 4 3Ghz, 2 GB RAM.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,11759,11759#msg-11759

On Wed, Oct 07, 2009 at 03:46:44AM -0400, gedakos wrote:

make[1]: Leaving directory `/tmp/nginx-0.7.59’
This happens with any of the versions. Can you please tell me if I’m doing something wrong or is it something I’ve missed ?
Try the attached patch.

Hello again.

First I would like to thank for your reply.
I’ve tried applying the patch you provided, but I can’t get pass the
following:

patch -p1 < …/patch.crl.txt

can’t find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:

|Index: src/http/modules/ngx_http_ssl_module.c
|===================================================================
|— src/http/modules/ngx_http_ssl_module.c (revision 2446)

+++ src/http/modules/ngx_http_ssl_module.c (working copy)

File to patch:

Am i doing something wrong or are there any extra prerequisites ?

Thank you in advance,
Bogdan Zglobiu

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,11759,13054#msg-13054

Hello!

On Mon, Oct 12, 2009 at 03:16:50AM -0400, gedakos wrote:

Hello again.

First I would like to thank for your reply.
I’ve tried applying the patch you provided, but I can’t get pass the following:

patch -p1 < …/patch.crl.txt

can’t find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?

You don’t need “-p1” here.

Maxim D.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs