Passenger - Internation Server Error


#1

Hello,

I was just trying to use Passenger to depoloy my rails application of my
VPS:
Apache:2.2.3 (Debian) PHP:5.2.0-8+etch13 Phusion_Passenger/2.1.2 Server

but I get the following error:

Internal Server Error

The server encountered an internal error or misconfiguration and was
unable to complete your request.

Please contact the server administrator, [no address given] and inform
them of the time the error occurred, and anything you might have done
that may have caused the error.

More information about this error may be available in the server error
log.

Passenger mentioned that their errors are logged into apache’s error log
I looked into the Apache error log (tail /var/log/apache2/error.log):
[Sat Mar 14 12:54:08 2009] [notice] Apache/2.2.3 (Debian)
PHP/5.2.0-8+etch13 Phusion_Passenger/2.1.2 configured – resuming normal
operations
[Sat Mar 14 12:54:18 2009] [alert] [client 24.83.34.176]
/var/www/current/public/.htaccess: Option FollowSymLinks not allowed
here

I don’t think it’s an Apache configuration issue because if I point to
the parent directory (/var/www/current/) instead of
(/var/www/current/public) I can see the files displayed.

Do you have any ideas what the problem might be or how I can dig more
about this problem.

Thanks,

Tam


#2

try to rename .htaccess to _htaccess (or delete), or add to apache
config file

<Directory /var/www/current/public/>
AllowOverride AuthConfig

tom

Tam K. wrote:

The server encountered an internal error or misconfiguration and was
Passenger mentioned that their errors are logged into apache’s error log
the parent directory (/var/www/current/) instead of
(/var/www/current/public) I can see the files displayed.

Do you have any ideas what the problem might be or how I can dig more
about this problem.

Thanks,

Tam

Tomas Meinlschmidt, MS {MCT, MCP+I, MCSE, AER}, NetApp Filer/NetCache

www.meinlschmidt.com www.maxwellrender.cz www.lightgems.cz


#3

Tom Z Meinlschmidt wrote:

try to rename .htaccess to _htaccess (or delete), or add to apache
config file

Thanks a lot Tom. This worked! I highly appreciate your help :wink:
Thanks,
Tam