Passenger->fastthread.c1 will not compile

Good Day,

I am trying to get passenger running on one of our servers at work but
when I run gem install passenger

it seems not to be compiling
here is the Output i am getting

[email protected] jeff]# gem install passenger
Building native extensions. This could take a while…
ERROR: Error installing passenger:
ERROR: Failed to build gem native extension.

/usr/bin/ruby extconf.rb
creating Makefile

make
gcc -I. -I/usr/lib/ruby/1.8/i686-linux -I/usr/lib/ruby/1.8/i686-linux
-I. -fPIC -O2 -g -march=i686 -Wall -fPIC -c fastthread.c
fastthread.c:1: error: CPU you selected does not support x86-64
instruction set
make: *** [fastthread.o] Error 1

Gem files will remain installed in
/usr/lib/ruby/gems/1.8/gems/fastthread-1.0.7 for inspection.
Results logged to
/usr/lib/ruby/gems/1.8/gems/fastthread-1.0.7/ext/fastthread/gem_make.out
[[email protected] jeff]#

This box is run centos 5.4(Final)
kernel:"Linux xxxx.xxxx 2.6.18-164.11.1.el5xen #1 SMP Wed Jan 20
08:06:04 EST 2010 x86_64 x86_64 x86_64 GNU/Linux|

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs