Passenger and 403s

I am setting up Passenger on my dev box and I am running into an issue
getting the ServerName on a vHost to work. The code below allows
localhost to work as planned. However when I try to pull up the app
using the ServerName “livewiredmusic.local” I always get a 403.

Also, I installed the Passenger Pref Pane just to see if that would
work, but I get the same 403 using the code it generates. FYI I
followed Ryan B. screencast…

I gave the app’s public dir 777 at one point as well and still got the

This is my httpd.conf:

NameVirtualHost :80
<VirtualHost :80>
ServerName livewiredmusic.local
DocumentRoot /Users/elliott/Documents/
<Directory “/Users/elliott/Documents/***/WebSites/”>
Order allow,deny
Allow from all

Then in /etc/hosts I added: livewiredmusic.local

Thanks for the help!

Any insight on this guys?

So… The fix was this.

I know very little about networking,DNS and IP protocol variants, for
whatever reason setting my server name to bind to in /etc/
hosts was not working.

Instead either
fe80::1%lo0 livewiredmusic.local
::1 livewiredmusic.local

worked fine.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs