Pas doué

Bon voila je veux essayer rails à l’installation j’ai quelques lignes
inquiètantes à la fin :
[[email protected] toto]# gem install rails --include-dependencies
Attempting local installation of ‘rails’
Local gem file not found: rails*.gem
Attempting remote installation of ‘rails’
Updating Gem source index for: http://gems.rubyforge.org
Successfully installed rails-1.1.6
Successfully installed rake-0.7.1
Successfully installed activesupport-1.3.1
Successfully installed activerecord-1.14.4
Successfully installed actionpack-1.12.5
Successfully installed actionmailer-1.2.5
Successfully installed actionwebservice-1.1.6
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require__': no such file to load -- rdoc/rdoc (LoadError) from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from /usr/lib/ruby/site_ruby/1.8/rubygems/doc_manager.rb:43:in
generate_rdoc' from /usr/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:215:inexecute’
from /usr/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:214:in
each' from /usr/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:214:inexecute’
from /usr/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:153:in
each' from /usr/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:153:inexecute’
from /usr/lib/ruby/site_ruby/1.8/rubygems/command.rb:49:in
invoke' from /usr/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:94:inprocess_args’
from /usr/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:67:in
run' from /usr/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:13:inrun’
from /usr/bin/gem:17

et évidemment durant mon premier exercice je retrouve ça :

127.0.0.1 - - [18/Nov/2006:18:53:49 CET] “GET /say/hello HTTP/1.1” 200 0

  • -> /say/hello
    [2006-11-18 18:53:49] ERROR MissingSourceFile: no such file to load –
    irb
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
    require__' /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
    require' /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/breakpoint.rb:18 /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:140:inload’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:140:in
    load' /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:56:inrequire_or_load’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:30:in
    depend_on' /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:85:inrequire_dependency’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:98:in
    const_missing' /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:131:inconst_missing’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:133:in
    send' /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:133:inconst_missing’
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/dispatcher.rb:75:in
    reset_after_dispatch' /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/dispatcher.rb:46:indispatch’
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/webrick_server.rb:115:in
    handle_dispatch' /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/webrick_server.rb:81:inservice’
    /usr/lib/ruby/1.8/webrick/httpserver.rb:104:in service' /usr/lib/ruby/1.8/webrick/httpserver.rb:65:inrun’
    /usr/lib/ruby/1.8/webrick/server.rb:173:in start_thread' /usr/lib/ruby/1.8/webrick/server.rb:162:instart’
    /usr/lib/ruby/1.8/webrick/server.rb:162:in start_thread' /usr/lib/ruby/1.8/webrick/server.rb:95:instart’
    /usr/lib/ruby/1.8/webrick/server.rb:92:in each' /usr/lib/ruby/1.8/webrick/server.rb:92:instart’
    /usr/lib/ruby/1.8/webrick/server.rb:23:in start' /usr/lib/ruby/1.8/webrick/server.rb:82:instart’
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/webrick_server.rb:67:in
    dispatch' /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/commands/servers/webrick.rb:59 /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire__’
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
    require' /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:inrequire’
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/commands/server.rb:30
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
    require__' /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
    `require’
    script/server:3

et mon browser reste blanc…

Une idée où j’ai pu merder?

Merci à vous.

Toto84

Bonjour,
des précisions :
l’installation a été faite sur une fédora 6, j’ai xp sur le même ordi,
j’ai installé rails sur xp, créé une appli sur un autre disque en fat
elle fonctionne sur xp, si je boote sur fédora je peux lancer webrick de
l’appli créée sur le disque fat et j’ai le même problème, j’accède à la
page de rails sur le port 3000 mais les appels au controller ne donne
rien : pas de message d’erreur, page blanche.
j’ai essayé une réinstallation de fédora et de rails, rien de nouveau.
Je ne suis pas trés fort en linux mais je connais un peu et j’aimerais
bien tester rails sur cet os.
J’aimerais savoir quelle distribution linux marcherait avec quelle
version de rubygems s’il vous plait.

2006/11/18, toto84 [email protected]:

Bon voila je veux essayer rails à l’installation j’ai quelques lignes
inquiètantes à la fin : […]

Salut,

Je viens juste de recevoir ton mail alors qu’il date de quelques jours.

Assure-toi que les paquets RPM d’irb et de rdoc soient bien
présents. Vérifie qu’irb et script/console marchent bien.

Dis-nous si ça te fait progresser,

bon courage,

РJean-Fran̤ois.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs