Parser para tildes en html

Hola

Conoceís algún parser para que al meter un texto en el html, sacado de
una bbdd con tildes, no te lo ponga así?? �

He mirado aquí:

Y con el sanitize nada de nada. Me lo deja igual.

Conoceís algo??

Muchas gracias

On 25/10/2007, Ramón Castro [email protected] wrote:

Hola

Conoceís algún parser para que al meter un texto en el html, sacado de
una bbdd con tildes, no te lo ponga así?? �

¿En qué encoding tienes la base de datos y en qué encoding sirves las
páginas?


Manuel, que
piensa que eres una excelente persona y medra en torno a
http://simplelogica.net y/o http://simplelogica.net/logicola/
Recuerda comer mucha fruta y verdura.

Manuel González Noriega wrote:

On 25/10/2007, Ramón Castro [email protected] wrote:

Hola

Conoceís algún parser para que al meter un texto en el html, sacado de
una bbdd con tildes, no te lo ponga así?? �

¿En qué encoding tienes la base de datos y en qué encoding sirves las
páginas?


Manuel, que
piensa que eres una excelente persona y medra en torno a
http://simplelogica.net y/o http://simplelogica.net/logicola/
Recuerda comer mucha fruta y verdura.

Los dos están en ISO-8859-1

On 25/10/2007, Ramón Castro [email protected] wrote:

Los dos están en ISO-8859-1

Mmmm, no debería dar problemas. ¿Las plantillas también las guardas
como 8859? ¿Seguro que estás sirviendo la página en iso-8859-1? No te
fies del elemento META, que no sirve para (casi) nada.


Manuel, que
piensa que eres una excelente persona y medra en torno a
http://simplelogica.net y/o http://simplelogica.net/logicola/
Recuerda comer mucha fruta y verdura.

Miguel Michelson wrote:

en tu config/database.yml pon lo siguiente

development:

encoding: utf8 #para los accentos
adapter: mysql
database: my_db
username: root
password: admin
host: localhost

yo lo hago asi, y no me presenta esos problemas

Saludos

On 10/25/07, Manuel González Noriega [email protected]

Muchas gracias a todos.

Con el encoding: utf8 en el database.yml me funciona perfectamente

Lo dicho gracias :wink:

Mmmm, no deber�a dar problemas. �Las plantillas tambi�n las guardas
como 8859? �Seguro que est�s sirviendo la p�gina en iso-8859-1? No te
fies del elemento META, que no sirve para (casi) nada.

Yo lo he mirado en el Meta. Si no es ahí dónde lo puedo ver??

Muchas gracias

en tu config/database.yml pon lo siguiente

development:

encoding: utf8 #para los accentos
adapter: mysql
database: my_db
username: root
password: admin
host: localhost

yo lo hago asi, y no me presenta esos problemas

Saludos

On 10/25/07, Manuel González Noriega [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs