Parameter not taken into account on a specific link structure

I have WP installed on my VPS (with nginx 1.3.12 and php5-fpm 5.4.11).

The first page of search results (/?s=test) is loaded properly, but
/page/2/?s=test displays the same content of /page/2/ (so ?s=test isn’t
taken into account).

It’s probably something wrong with my nginx config:

location ~ .php$ {
try_files $uri =404;
fastcgi_split_path_info ^(.+.php)(/.+)$;
include /etc/nginx/fastcgi.conf;
fastcgi_pass unix:/var/run/php5-fpm.sock;
}

location / {

if you’re just using wordpress and don’t want extra rewrites

then replace the word @rewrites with /index.php

try_files $uri $uri/ /index.php;

}

Articles work fine anyway… the permalink structure
(/%year%/%monthnum%/%day%/%postname%/) works fine… so I should find a
fix
that doesn’t break that (but “fixes” the search parameter problem).

“DEMO”
Page 1 (/?s=test): http://goo.gl/HigKa
Page 2 (/page/2/?s=test): http://goo.gl/ujftR

Thanks in advance.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs