Paperclip upload fails sometimes

Hello,

My application is a rails-postgresql application which uses paperclip
(“ImageMagick-6.5.4-10-Q16-windows-dll.exe” installed on WinXP).

The application’s image uploading feature works consistently right on
my development PC, however it is inconsistent on a different server PC
(used for deployment).

There are certain observations below.

a) For the first time the file gets uploaded right.
b) The same file if attempted for again, twice, thrice, gets uploaded
right.
c) At the fourth time (may not necessarily be at the fourth time, but
often it is), it fails with this error - C:/…/stream.1644.0 is not
recognized by the ‘identify’ command.
d) This happens with any file as such and the file is not at fault.
e) Some time after the occurrence of this error, I attempted again (w/
o restarting my web server), it worked! But again in the next attempt

  • the same error gets shown. Then again, it worked.
    f) There is a slightly uncertain behavior with this upload - it works
    if tried again (may be after some time).
    g) However, on my development PC, this is not the case. It works right
    consistently.

The a few people have been saying that the cause of this error could
be that the path to Imagemagick - identify.exe is incorrectly set.
But, then the image upload works as well (can work right only if the
path is correct) - so I do not suspect it to be a path problem.

Request any possible help with this situation. Thanks in advance.

love-n-peace,
@shaan
‘Aal izz well’ shaan

Posts: 5
Joined: 2010-02-24T08:33:52+00:00
Private message

I am experiencing great problems uploading with Safari. Which browser
are you using?

Hi,

Internet explorer 6.0. Any clue on this situation?

@shaan

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs