Paperclip Gem Successfully Installed? If yes its doesn't seem to detect via IRB

Hi,

I am trying to install a paperclip gem using the command

gem install paperclip-2.2.0.gem . This doesn’t work for me… it keeps
giving me the error…

[email protected]:~/Downloads/Important_backups/new_gems/paperclip$

gem install paperclip-2.2.0.gem
ERROR: While executing gem … (Zlib::GzipFile::Error)
not in gzip format

I checked my gem sources and it shows:-

[email protected]:~/Downloads/Important_backups/new_gems/paperclip$

gem sources
*** CURRENT SOURCES ***

http://rubygems.org/
[email protected]:~/Downloads/Important_backups/new_gems/paperclip$

I have a feeling this doesn’t work as I am behind a proxy( working from
office ).
I am not sure if this is the reason… can anybody who reads this ,
please confirm the same.

When I manually downloaded the gems and tried to install the same with
the extra -l(its a minus l(el) and not a minus one as it looks
like). It worked. Is it that “-l” takes the gems from the local box ,
from the location where they are installed/present…? :-

[email protected]:~/Downloads/Important_backups/new_gems/paperclip$

gem install paperclip-2.2.0.gem -l
Successfully installed right_http_connection-1.2.1
Successfully installed right_aws-1.9.0
Successfully installed thoughtbot-shoulda-2.11.1
Successfully installed paperclip-2.2.0
4 gems installed
Installing ri documentation for right_http_connection-1.2.1…
Installing ri documentation for right_aws-1.9.0…
Installing ri documentation for thoughtbot-shoulda-2.11.1…
Installing ri documentation for paperclip-2.2.0…
Installing RDoc documentation for right_http_connection-1.2.1…
Installing RDoc documentation for right_aws-1.9.0…
Installing RDoc documentation for thoughtbot-shoulda-2.11.1…
Installing RDoc documentation for paperclip-2.2.0…
[email protected]:~/Downloads/Important_backups/new_gems/paperclip$
gem sources

I am really not sure if this gem is fully installed successfully… . I
tried to check the same in my rails app using the IRB and this is what I
got… I would like to also add that I am making use of RVM currently
and I keep switching between versions 1.8.7 and 1.9.2 :-

[email protected]:~/UP/pocs_tried_for_use/post_with_image$

ruby script/console
Loading development environment (Rails 2.0.2)
ruby-1.8.7-p334 :001 > require ‘paperclip’
=> []
ruby-1.8.7-p334 :002 > exit
[email protected]:~/UP/pocs_tried_for_use/post_with_image$
[email protected]:~/UP/pocs_tried_for_use/post_with_image$ gem
list

*** LOCAL GEMS ***

aasm (2.2.0, 2.1.1)
action_profiler (1.0.0)
actionmailer (2.3.5, 2.0.2)
actionpack (2.3.5, 2.0.2)
activerecord (2.3.5, 2.0.2)
activeresource (2.3.5, 2.0.2)
activesupport (3.0.0, 2.3.5, 2.0.2)
acts_as_reportable (1.1.1)
aws-s3 (0.6.2)
builder (2.1.2)
cgi_multipart_eof_fix (2.5.0)
color (1.4.1)
contacts (1.2.4)
daemons (1.1.0)
fastercsv (1.5.3)
fastthread (1.0.7)
ferret (0.11.6)
gdata (1.1.1)
gem_plugin (0.2.3)
gettext (2.1.0)
hoe (2.6.2)
hpricot (0.8.3, 0.8.2)
httpclient (2.1.5.2)
image_science (1.2.1)
json (1.4.6)
json_pure (1.4.6)
locale (2.0.5)
log4r (1.1.8)
macaddr (1.0.0)
mechanize (1.0.0)
memcache-client (1.8.5)
mime-types (1.16)
mocha (0.9.8)
mongrel (1.1.5)
mysql (2.8.1)
nokogiri (1.4.3.1)
paperclip (2.2.0)
passenger (2.2.4)
pdf-writer (1.1.8)
prawn (0.8.4)
prawn-core (0.8.4)
prawn-layout (0.8.4)
prawn-security (0.8.4)
rack (1.0.1)
railroad (0.5.0)
rails (2.0.2)
rake (0.8.7)
RedCloth (3.0.3)
rfacebook (0.9.8, 0.9.0)
right_aws (1.9.0)
right_http_connection (1.2.1)
rmagick (2.9.1)
ruby-activeldap (0.8.3.1)
ruby-net-ldap (0.0.4)
ruby-openid (2.1.8, 2.0.2)
rubyforge (2.0.4)
rubygems-update (1.3.7)
ruport (1.6.3)
scrubyt (0.4.06)
thoughtbot-shoulda (2.11.1)
tinyurl (1.0.0)
transaction-simple (1.4.0)
uuid (2.3.1)
xml-simple (1.0.12)
[email protected]:~/UP/pocs_tried_for_use/post_with_image$

ruby -v
ruby 1.8.7 (2011-02-18 patchlevel 334) [i686-linux]
[email protected]:~/UP/pocs_tried_for_use/post_with_image$
rails -v
Rails 2.0.2
[email protected]:~/UP/pocs_tried_for_use/post_with_image$

I have added a require ‘paperclip’ in my environment.rb and my post.rb
model.

Is there any other way , I can check if this gem or any other gem for
that matter is successfully installed or not…?

Kindly guide me on this.

Thank you…

Thanks for your inputs.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs