Page Display Error

Hi Everyone, this is my first post. So I’ll try to be as detailed as
possible.

Dev Machine: OSX 10.5.2
Ruby: 1.8.6 (2007-09-24 patchlevel 111) [universal-darwin9.0]
Rails: 2.0.2
Using MAMP 1.7.1 with the following settings
PHP: 5.2.5
MYSQL : 5.0.41
Using CocoaMySQL .7b5
TextMate 1.5.7

I’ve built several sites using basic HTML, PHP, ASP, ect, but this is my
first jump into web2.0 development.

I’m learning ruby on rails and am going through some of the tutorials.
Some tutorials work fine, ei.

Others don’t. They say they are written for rails 2.+ and ruby 1.8.6
but the result I get is nearly universal.
Take the example below from

I get to the step after creating the migration file
“001_create_movies.rb”. I run rake db:migrate, verify with cocoamysql
that the tables and fields are created properly. They do so I run ruby
script/server.

The server loads up as expected http://localhost:3000. But when I
navigate to http://localhost:3000/movies I DO NOT get the expected
results.
I am missing the description field and one_sheet_url field. I followed
the instructions to the letter up to that point. Again, this similar
result has happened with other tutorials so I think the error is
somewhere on my end.

This is what I should have:



I case the pics don’t come up above:


But I get this:


I case the pics don’t come up above:



Here is the output from terminal: http://pastie.caboo.se/170436

I’ve tried the page in safari 3.1 and firefox 3b4. Like I said this
only happens with certain tutorials I go through. I’m a noob at this so
its frustrating not understanding why this is happening. If anyone can
help clear this up for me I would greatly appreciate it. Thank you for
your time,
Shai

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs