Page_attachment didnt works!


#1

hello!

I’m istalled a page_attachment (i migrated database and copy code to
proper directories) in my radiant cms site on mediatemple, and this
plugin didn’t works. What i do wrong?

thanks


#2

rake radiant:freeze:edge
rake radiant:extensions:page_attachments:update

Restart your app server.

Sean


#3

Sean C. wrote:

rake radiant:freeze:edge
rake radiant:extensions:page_attachments:update

still this same. i’m currently on mediatemple.


#4

here is also result of my rake command:

rake radiant:extensions:page_attachments:update RAILS_ENV=production
(in /home/x/containers/rails/y)
Loaded suite /home/x/data/rubygems/gems/bin/rake
Started

Finished in 0.000179 seconds.


#5

i also use TinyMCE extension, maybe this one causes the problem?


#6

Sean C. wrote:

rake radiant:freeze:edge
rake radiant:extensions:page_attachments:update

Restart your app server.

Sean

And on rake radiant:extensions:page_attachments:update
I have:
C:\radiant>rake radiant:extensions:page_attachments:update
(in C:/radiant)
rake aborted!
Don’t know how to build task
‘radiant:extensions:page_attachments:update’

Any ideas?:slight_smile:


#7

maybe someone post a FULL instruction how to install page_attachment
plugin? please. i’m try to do this from scrathch.


#8

rake radiant:extensions:page_attachments:update

rake radiant:extensions:page_attachments:update RAILS_ENV=production
(in /home//containers/rails/)
Loaded suite /home/*/data/rubygems/gems/bin/rake
Started

Finished in 0.000185 seconds.

0 tests, 0 assertions, 0 failures, 0 errors

So…nothing will happen on this command.


#9

Heh, it just looks like it doesn’t do anything. If you check your
public directory you should find javascripts/page_attachments.js and
stylesheets/page_attachments.css were added.

Sean


#10
  1. Follow the general instructions (available on the Wiki, weblog, and
    mailing list archive) for installing Radiant and creating a new
    “project”, including initializing the database.
  2. From the root of your Radiant project/instance, run these commands in
    order:

svn export
http://svn.seancribbs.com/svn/rails/plugins/extensions/page_attachments
vendor/extensions/page_attachments

rake db:migrate:extensions
rake radiant:freeze:edge
rake radiant:extensions:page_attachments:update

(those rake commands can be combined into one if you want)

  1. Start up or restart your application server.

If you continue to have problems, please contact me privately.

Sean


#11

Adam,

If all else fails, yes you can just copy it manually.

Sean


#12

I found when I went through this process earlier today that on step 4
http://dev.radiantcms.org/radiant/wiki/InstallingPageAttachments,
instead of ‘rake radiant:extensions:page_attachments:update’, I
needed to specify the environment ‘rake production
radiant:extension…’

If a person sets up a valid development environment, the command as
written probably won’t give an error, but won’t copy the files to the
right place either.

dm


#13

I have the same problem and i looked for the .js but couldn’t find it.
404 Not Found [http://0.0.0.0/javascripts/page_attachments.js]
The install procedure was quite simple so I can’t understand what went
wrong but the file just isn’t there. I probably made some sort of
mistake, maybe I could just copy the .js manually?