[OT] Hosed ImageMagick Kills Gruff

This is off-topic because it’s installation specific, but I wondered if
anyone could point me in the right direction. I installed ImageMagick
and
RMagick on my MacBook Pro using Darwin Ports and the normal gem install,
respectively. I got the dreaded “bus error.”

I read Tom M.'s discussion about installing GraphicsMagic and then
RMagick, so I used port uninstall and gem uninstall to (theoretically)
clean
up the system, then did a port install GraphicsMagick. I then installed
RMagick, but it’s still looking for ImageMagick.

Is there some recommended way to configure this?

TIA

View this message in context:
http://www.nabble.com/-OT--Hosed-ImageMagick-Kills-Gruff-tf2543016.html#a7085749
Sent from the RubyOnRails Users mailing list archive at Nabble.com.

On 10/30/06, s.ross [email protected] wrote:

RMagick, but it’s still looking for ImageMagick.

Is there some recommended way to configure this?

strange, i didn’t have any problem installing imagemagick/rmagick
using macports and gem in conjunction. might you have a dated macports
(nee darwinports) install? you should run ‘sudo port selfupdate’
regularly to update macports itself and all the port files. afterwards
you can run ‘port outdated’ to see if any of the ports you have
installed are outdated and upgrade as per necessary.

this should do it in one fell swoop:
% sudo port selfupdate
% sudo port -f install ImageMagick
% sudo port install rb-rubygems
% sudo gem install rmagick

cheers,
jean-pierre

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs