[OT] building fastcgi


#1

Following the instructions on Hivelogic, everything works flawlessly on
my
Powerbook until I do the 'sudo gem install fcgi.

I’m getting no-definition errors all over the place. Any thoughts how to
resolve this?

Example of errors:

No definition for fcgi_s_accept

No definition for fcgi_s_each

No definition for fcgi_s_each

No definition for fcgi_s_iscgi

View this message in context:
http://www.nabble.com/-OT-building-fastcgi-t1327794.html#a3544682
Sent from the RubyOnRails Users forum at Nabble.com.


#2

Try this:

sudo gcc_select 3.3

whether it works or not…

sudo gcc_select 4.0

afterward to put it back into “stock” form.


– Tom M.


#3

gcc_select didn’t solve the problem. Any other places to look?

Thanks

View this message in context:
http://www.nabble.com/-OT-building-fastcgi-t1327794.html#a3544977
Sent from the RubyOnRails Users forum at Nabble.com.


#4

Did you install fcgi itself, before the gem?

Yep. Clean build, clean install. Believe me, I’ve done the steps on
Hivelogic more often than once… Just can’t get fastcgi running.

View this message in context:
http://www.nabble.com/-OT-building-fastcgi-t1327794.html#a3545450
Sent from the RubyOnRails Users forum at Nabble.com.


#5

Sorry to respond to my own post, but it looks like the gem may have
installed
correctly. Still, fastcgi is upchucking… The error I get is:

=> Booting lighttpd (use ‘script/server webrick’ to force WEBrick)
=> Rails application started on http://0.0.0.0:3005
=> Call with -d to detach (requires absolute paths in
config/lighttpd.conf)
=> Ctrl-C to shutdown server (see config/lighttpd.conf for options)
2006-03-23 16:41:45: (mod_fastcgi.c.989) execve failed for:
public/dispatch.fcgi
No such file or directory
2006-03-23 16:41:45: (mod_fastcgi.c.1015) the fastcgi-backend
public/dispatch.fc
gi failed to start:
2006-03-23 16:41:45: (mod_fastcgi.c.1019) child exited with status 2
public/disp
atch.fcgi
2006-03-23 16:41:45: (mod_fastcgi.c.1022) if you try do run PHP as
FastCGI
backe
nd make sure you use the FastCGI enabled version.
You can find out if it is the right one by executing ‘php -v’ and it
should
disp
lay ‘(cgi-fcgi)’ in the output, NOT (cgi) NOR (cli)
For more information check
http://www.lighttpd.net/documentation/fastcgi.html#pr
eparing-php-as-a-fastcgi-program
2006-03-23 16:41:45: (mod_fastcgi.c.1027) If this is PHP on Gentoo add
fastcgi t
o the USE flags
2006-03-23 16:41:45: (mod_fastcgi.c.1314) [ERROR]: spawning fcgi failed.
2006-03-23 16:41:45: (server.c.670) Configuration of plugins failed.
Going
down.

View this message in context:
http://www.nabble.com/-OT-building-fastcgi-t1327794.html#a3563741
Sent from the RubyOnRails Users forum at Nabble.com.


#6

Did you install fcgi itself, before the gem?


– Tom M.