OSX Rails Session Issues


#1

Hey friends,

I need a little assistance getting one of my applications running on
OSX.

I am able to install everything, and get my application running, but
when I try to store an object in the session in one of my apps, the
session object doesn’t get stored.

I tried running webrick, and I tried running under lighttpd.

I tried running a regular session store, and a mysql session store.

I created a new application, and in that instance I was ABLE to store
things in the session.

I’m running the same code on windows and on a red hat production box,
and neither have problems storing the model in the session.

Has anyone else run into this issue? Any ideas?

Thanks in advance,

-Gregg


#2

Does the application server have write access to the disk location that
the session files are being stored in?


#3

Hi!

On May 23, 2006, at 9:46 PM, Jim C. wrote:

OSX.

Thanks in advance,

-Gregg

Gregg-

Have you set a custom session domain anywhere in your environment

files? Like:

ActionController::CgiRequest::DEFAULT_SESSION_OPTIONS.update
( :session_domain => ‘.foo.com’)

I ran into this error once where I had set the session domain and

forgot about it. So anything you stored in the session would be gone
on the next request.

-Ezra