OSX configure error

Hello all,

I am trying to install GNU-Radio on my PowerBook G4 1.67GHz with OS X
10.4.11
I read the OS X build instructions from RadioWare. But get error during
the
installation
of the dependent packages from Macports. I can’t install the sdcc
compiler,
so that is
not the problem because I am a GNURadio beginner and for the first time
I
don’t need
the usrp part of GNU-Radio. So I type in ./configure --disabel-usrp the
problem is that
the configure script quit with the error:

configure: error: cannot find usable Python headers

But the Python interpreter is installed and is working:

q68f0:~/gnuradio josefvukovic$ python
Python 2.5.4 (r254:67916, Aug 6 2009, 10:03:18)
[GCC 4.0.1 (Apple Computer, Inc. build 5370)] on darwin
Type “help”, “copyright”, “credits” or “license” for more information.

quit
Use quit() or Ctrl-D (i.e. EOF) to exit

q68f0:~/gnuradio josefvukovic$

Could someone be so kind to give me a hint what can I do :frowning:

cu
Josef V.

I do not know exactly what your problem is, but it’d probably be good to
post your path variable (type path in the terminal and post what you
get)

2009/8/6 Josef V. [email protected]

2009/8/6 Jonathan C. [email protected]

I do not know exactly what your problem is, but it’d probably be good to
post your path variable (type path in the terminal and post what you get)

Thanks for your answer :slight_smile:

path dont work see:

q68f0:~/gnuradio josefvukovic$ echo $PATH
/opt/local/bin:/sw/bin:/sw/sbin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11R6/bin
q68f0:~/gnuradio josefvukovic$ path
-bash: path: command not found
q68f0:~/gnuradio josefvukovic$ printenv
LDFLAGS=-L/opt/local/lib -L/sw/lib
MANPATH=/opt/local/share/man:/sw/share/man:/usr/local/share/man:/usr/share/man:/usr/X11R6/man:/sw/lib/perl5/5.8.6/man
TERM_PROGRAM=Apple_Terminal
TERM=xterm-color
SHELL=/bin/bash
PERL5LIB=/sw/lib/perl5:/sw/lib/perl5/darwin
TERM_PROGRAM_VERSION=133-1
USER=josefvukovic
__CF_USER_TEXT_ENCODING=0x1F5:0:0
PYTHON_VERSION=2.3
PATH=/opt/local/bin:/sw/bin:/sw/sbin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11R6/bin
PWD=/Users/josefvukovic/gnuradio
LANG=de_DE.ISO8859-1
SHLVL=1
HOME=/Users/josefvukovic
PYTHON_ROOT=/usr
PYTHONPATH=/usr/lib/python2.3/site-packages:/usr/local/lib/python2.3/site-packages
PKG_CONFIG_PATH=/opt/local/lib/pkgconfig:/sw/lib/pkgconfig:/usr/local/lib/pkgconfig:/usr/lib/pkgconfig:/usr/X11R6/lib/pkgconfig
INFOPATH=/opt/local/share/info:/sw/share/info:/sw/info:/usr/local/share/info:/usr/share/info
SECURITYSESSIONID=b06940
_=/usr/bin/printenv
OLDPWD=/Users/josefvukovic
q68f0:~/gnuradio josefvukovic$

Probably the error is in the PYTHONPATH variable, I installed python
2.5
and in the environmentvariable is mentioned python2.3

How can I fix this ?

cu
Josef V.

Yeah, if it’s pointing do 2.3 that should definitely be a problem

Are you using this guide?
https://radioware.nd.edu/documentation/install-guides/mac-os-x

Tips that I was given (as I am not an expert, but want to pay forward
that
help so Michael isn’t always responding to mac complaints): use x11, and
setting up the .bashrc is important. You’re probably going to need to go
into your profile and ensure it’s points to the right place. The given
link
has commands to add. I had some problems with python, and hacking that
out
got rid of all of them (didn’t get rid of all my problems, though :P)

2009/8/6 Josef V. [email protected]

Yes, Iam using this guide :slight_smile:
X11 don’t helps there are the same errors from runnign ./configure
My .basrc is configured like sugestet in the RadioWare guide.

Please Help :frowning: me.

2009/8/6 Jonathan C. [email protected]

Are you installing from the tarball or from the svn repository? If it’s
the
former, you shouldn’t bootstrap. If it’s the latter, you should, but
there
is a special command you need to create for it.
https://radioware.nd.edu/documentation/install-guides/mac-os-x/obtaining-and-installing-gnu-radio
sed -e ‘[email protected]@[email protected]’ bootstrap > bootstrap_mp && sh
bootstrap_mp

2009/8/11 Josef V. [email protected]

I have resolved this porblem.
The error don’t appear when the ./bootstrap script is not run
before the ./configure script is run.
So don’t make a configure scritpt with ./bootstrap instead run
simply ./configure.

cu
Josef V.

2009/8/6 Josef V. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs