Org.jruby.jcodings/jcodings==1.0.5 bad sha1 on Maven Central

Howdy, all –

I’m trying to use the split-out (as opposed to -complete) build of JRuby
from Maven.

At present, this fails:

[antlib:org.apache.ivy.ant:install] :: problems summary ::
[antlib:org.apache.ivy.ant:install] :::: WARNINGS
[antlib:org.apache.ivy.ant:install] problem while downloading module
descriptor:
http://mirrors.ibiblio.org/maven2/org/jruby/jcodings/jcodings/1.0.5/jcodings-1.0.5.pom:
invalid sha1: expected=7a5c5ce95065fb77235c4b87e481a16c9b1e982b
computed=97192329d3c86d80a20415f497f17565ef0de2d0 (2ms)
[antlib:org.apache.ivy.ant:install] module not found:
org.jruby.jcodings#jcodings;1.0.5
[antlib:org.apache.ivy.ant:install]
::::::::::::::::::::::::::::::::::::::::::::::
[antlib:org.apache.ivy.ant:install] :: UNRESOLVED
DEPENDENCIES ::
[antlib:org.apache.ivy.ant:install]
::::::::::::::::::::::::::::::::::::::::::::::
[antlib:org.apache.ivy.ant:install] ::
org.jruby.jcodings#jcodings;1.0.5: not found
[antlib:org.apache.ivy.ant:install]
::::::::::::::::::::::::::::::::::::::::::::::

Looking at the published files, the .pom.sha1 file legitimately does not
match the checksum of the .pom.

I see a similar issue for org.jruby.extras.bytelist/bytelist==1.0.8:

[antlib:org.apache.ivy.ant:install] problem while downloading module
descriptor:
http://mirrors.ibiblio.org/maven2/org/jruby/extras/bytelist/1.0.8/bytelist-1.0.8.po
m: invalid sha1: expected=e40ee094403473e43f71e21cf9cbf71f08d2098b
computed=a9627bc7e42f886e290985367040794adb676320 (2ms)

What’s the history here?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs