Oracle oci8 utf8 corruption


#1

I have a small script oci1.rb:

require ‘oci8’
conn = OCI8.new(“test”,“test”,“test_db”)
File.open(“out.txt”,“wb”) do |out|
tabs = conn.exec(‘SELECT * from test_utf8’) do |r|
out.write(r.join(’,’))
out.write("\n")
end
end
conn.logoff

that runs perfectly on windows producing from my test_db:
polish,łóśżć
russsian,фывафыва
german,äöü

when I run exactly the same on my linux box:
polish,loszc
russsian,???
german,aou

I tested then a small script that reads and writes UTF8 on linux
(read_write_utf8.rb):
File.open(“utf8_out.txt”,“wb”) do |out|
File.open(“utf8.txt”,“r”).each do |line|
out.write(line)
end
end

and that works good!

chris@emeadb:~/work/ruby/oci$ ruby read_write_utf8.rb

chris@emeadb:~/work/ruby/oci$ cat utf8.txt
polish,łóśżć
russsian,фывафыва
german,äöü

chris@emeadb:~/work/ruby/oci$ cat utf8_out.txt
polish,łóśżć
russsian,фывафыва
german,äöü

where should I try to dig into to find out how to force the oracle
database data to be properly stored in the file on linux?
I just add that
LANG=en_US.UTF-8

thanks,
chris


#2

On May 28, 1:11Â pm, ciapecki removed_email_address@domain.invalid wrote:

conn.logoff

chris@emeadb:~/work/ruby/oci$ ruby read_write_utf8.rb

where should I try to dig into to find out how to force the oracle
database data to be properly stored in the file on linux?
I just add that
LANG=en_US.UTF-8

thanks,
chris

apparently setting NLS_LANG=AMERICAN_AMERICA.UTF8 (externally! - not
in the ruby script) did the trick.

chris


#3

krzysztof cierpisz wrote in post #821043:

On May 28, 1:11Â pm, ciapecki removed_email_address@domain.invalid wrote:

conn.logoff

chris@emeadb:~/work/ruby/oci$ ruby read_write_utf8.rb

where should I try to dig into to find out how to force the oracle
database data to be properly stored in the file on linux?
I just add that
LANG=en_US.UTF-8

thanks,
chris

apparently setting NLS_LANG=AMERICAN_AMERICA.UTF8 (externally! - not
in the ruby script) did the trick.

chris

I placed ENV[‘NLS_LANG’]=‘AMERICAN_AMERICA.UTF8’ as the first line in my
ruby script and it worked.