Oracle error

I got this error when trying to connect to the database:

C:/test/Ruby/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require’: OCI.DLL: 193(%1 is not a valid Win32 application. )
(LoadError)

what could’ve caused it?
Thanks

I have updated the oci.dll and got this error instead:

c:/test/Ruby/ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`initialize’: wrong number of arguments (2 for 0…1) (ArgumentError)

The steps:
I run “ruby refresh_test_data.rb”
and that’s it, I got that error.

I’m uploading the necessary codes

and FYI, the credentials provided in the config.yaml works (has been
tested from sqlplus console).

On Thu, Sep 19, 2013 at 12:43 PM, nebeng intiland
[email protected]wrote:

I have updated the oci.dll and got this error instead:

c:/test/Ruby/ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`initialize’: wrong number of arguments (2 for 0…1) (ArgumentError)

If you are using Oracle instant client, copy all dll files in the
package
to same location.

If you are using full client, don’t copy oci.dll. It must be at the
installed location.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs