Oracle connection problem

ORA-12154: TNS:could not resolve the connect identifier specified

I’ve updated rails to 2.0.2 and I start having a problem with oracle
connection.

I installed activerecord-oracle-adapter, and changed oci to oracle in
database.yml but I keep getting the oracle error
ORA-12154: TNS:could not resolve the connect identifier specified

Can someone help me with this problem?
Thanks.

Hi Sunny,

Do you follow the installation guide of Ruby-OCI8?
http://ruby-oci8.rubyforge.org/en/HowToInstall.html
If so, how is your database.yml like? can you connect to the DB using
sqlplus?
please provide more information so we can help you solve your problem :slight_smile:

2008/4/5, Sunny B. [email protected]:

Can someone help me with this problem?
Thanks.

Posted via http://www.ruby-forum.com/.


Cheers,
Jesse

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs