Opening old project

Hello there,

On friend asked me to update his rails app…

But it’s app was made with Rails 1.2.3 and I can not start it on my
computer, Leopard, Rails 2.3

Does anybody have any advice on opening and updating old projects?

thanks!

Luciano

Luciano wrote:

Hello there,

On friend asked me to update his rails app…

But it’s app was made with Rails 1.2.3 and I can not start it on my
computer, Leopard, Rails 2.3

Does anybody have any advice on opening and updating old projects?

thanks!

Luciano

Do you have Rails 1.2.3 installed or in the app’s vendor/rails
directory? If so, what errors are you getting? Just saying “it doesn’t
work” is not helpful.

Best,

Marnen Laibow-Koser
http://www.marnen.org
[email protected]

Hello Marnen,

I’m sorry for this short description!

this is the erro I got:

bb25452e:vavaribeiro bonacode$ ruby script/server
./script/…/config/boot.rb:25:Warning: Gem::SourceIndex#search support
for String patterns is deprecated
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment…
Exiting
/Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
gem_original_require': no such file to load -- zip/zip (MissingSourceFile) from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:inrequire’
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/
ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/
dependencies.rb:495:in require' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies.rb:342:innew_constants_in’
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/
ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/
dependencies.rb:495:in require' from ./script/../config/../lib/environment_extend.rb:12 from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies.rb:488:inload’
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/
ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/
dependencies.rb:488:in load' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies.rb:342:innew_constants_in’
… 28 levels…
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/
ruby/gems/1.8/gems/rails-1.2.3/lib/commands/server.rb:39
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:inrequire’
from script/server:3
bb25452e:vavaribeiro bonacode$

thanks

Luciano

On Jun 22, 8:08 pm, Marnen Laibow-Koser <rails-mailing-l…@andreas-

On 23 June, 00:19, Luciano [email protected] wrote:

Hello Marnen,

I’m sorry for this short description!

this is the erro I got:

It looks like you’re missing a gem as well. You should check what
gems are required for this project.

Robin

to start the old project as it is in your system you have to install
rails 1.2.3 So do this
gem install rails -v=1.2.3

Sijo

Sijo,

thanks for your advice, I installed Rails 1.2.3

but I think Robin is right, I must install some missing gems, I am
still getting those gems errors…

thanks to all you guys!

Luciano

You’re missing the rubyzip gem.

–Matt J.

thank you very much Matt!

[]s

Luciano