Do I have to make from new_dir a class variable? (the way I have it now)
Is there another way to do this?
I’d say, the first two options are most usual. If you don’t need the
var anywhere else, I’d use the first option. In other words, it
depends on the relationship of site object to the created directory.
If they are close enough, you can make it an instance variable
(@new_dir). Other possibility is to create a helper class SiteDir with
methods create and get_files, and @new_dir.
Do I have to make from new_dir a class variable? (the way I have it now)
Is there another way to do this?
It seems to me that method1 and method2 are more like functions (i.e.
they are defined on top level). In that case I’d pass the directory
name as argument to method2. It’s not completely clear to me, what
“magic code” does, but assuming that it generates the name then new_dir
should definitively be a return value from method1.
Another option is to refactor the code to create an additional function
magic_code that does nothing else than creating the directory name which
then is passed to method1 and method2.
There are other options like creating a helper class that contains all
these methods and has a member for the directory name. Then all methods
can access this name.
For more specific advice we would probably have to see the code or at
least get more information about the problem you are trying to solve.
My general advice is to create methods (and classes) that do one thing
and one thing only, i.e. proper modularize code. Your directory name
generation code seems to be a candidate for factoring out into another
method.