:only and :except not working for map.resources

Hi guys. I’m trying to get rid of some non-existing routes. My
UserSessionsController has three methods: new, create, and destroy.
However, in routes.rb , I’m generating the 7 RESTful routes:
map.resource :user_session

So, I thought that this would generate routes for the 3 actions that
do exist:
map.resource :user_session, :only => [:new, :create, :destroy]

However, after adding that, ``rake routes’’ still spits out the other
4 routes:
http://rafb.net/p/kRS3DD41.html

Any idea what’s going on here? Thanks,
Nick

Nick,

The :except and :only routing options are only available on Edge Rails
(Rails 2.2.1 or Rails 2.2 RC2) at this time. Make sure you are running
the correct version.

Cheers


Robert Z.
Zapient, LLC
Ruby on Rails Development and Consulting

http://www.zapient.com
http://www.fromjavatoruby.com

On Nov 15, 10:35 pm, Nick [email protected] wrote:

Thanks Robert. I had no idea that was the case. I figured that the
docs at api.rubyonrails.org were applicable to the current stable
version, rather than Edge.
-Nick

Ack, my bad. The :except and :only options aren’t listed on
api.rubyonrails.org yet. I found them in the “Rails Routing From The
Inside Out” Rails Guide:
http://guides.rubyonrails.org/routing_outside_in.html

On Nov 15, 5:47 pm, Robert Z. [email protected] wrote:

Zapient, LLC
Ruby on Rails Development and Consulting

http://www.zapient.comhttp://www.fromjavatoruby.com

Thanks Robert. I had no idea that was the case. I figured that the
docs at api.rubyonrails.org were applicable to the current stable
version, rather than Edge.
-Nick

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs