OneClickInstaller/RubyGems problems

Is there anything you have to do after installing the Windows
OneClickInstaller? I did so and then tried to use RubyGems with now
success. First I tried:

gem install rubyscript2exe

but got

getaddrinfo: no address associated with hostname.(SocketError)

I added --no-http-proxy and got:

underfined method ‘[]=’ for #Gem::ConfigFile:0x2df7864

So I download the latest 0.9.4 version of RubyGems and tried to
install it with setup.rb and got:

undefined method ‘file_name’ for #Gem::Specification:0x2e2b36c

Anyone know what’s up?

Thanks,
T.

On Sep 26, 2007, at 09:05 , Trans wrote:

Is there anything you have to do after installing the Windows
OneClickInstaller? I did so and then tried to use RubyGems with now
success. First I tried:

gem install rubyscript2exe

but got

getaddrinfo: no address associated with hostname.(SocketError)

This tells me that you weren’t attached to the internet, or were
having problems with DNS.

While there could be a corner I’ve missed, I don’t believe that
RubyGems prints out just an exception message and nothing else.
Please paste the full command output.

So I download the latest 0.9.4 version of RubyGems

Last I checked the one click installer shipped with 0.9.4. gem env
will give you the version of RubyGems you have installed.

Trans wrote:

I added --no-http-proxy and got:
Thanks,
T.

Are you behind a firewall? I’m not sure RubyGems is sneaky enough to
deal with proxy servers.

On Sep 26, 2007, at 19:25 , M. Edward (Ed) Borasky wrote:

Are you behind a firewall? I’m not sure RubyGems is sneaky enough to
deal with proxy servers.

RubyGems has dealt with proxy servers for ages.

On Sep 26, 4:35 pm, Eric H. [email protected] wrote:

getaddrinfo: no address associated with hostname.(SocketError)
Last I checked the one click installer shipped with 0.9.4. gem env
will give you the version of RubyGems you have installed.

I downloaded what was on ruby-lang.org and it install RubyGems 0.9.2;
I was able to upgrade to 0.9.4 manually --I ran setup.rb a second time
and somehow it resolved the problem there. However, I still get the
same errors trying to use RubyGems. This is the exact CLI text:

C:\Documents and Settings\Milton\My Documents\Tom>gem install
rubyscript2exe ERROR: While executing gem …
(Gem::RemoteFetcher::FetchError)
getaddrinfo: no address associated with hostname.(SocketError)

C:\Documents and Settings\Milton\My Documents\Tom>gem install
rubyscript2exe -n
o-http-proxy
ERROR: While executing gem … (NoMethodError)
undefined method `[]=’ for #Gem::ConfigFile:0x2e2ebc0

T.

Eric H. wrote:

On Sep 26, 2007, at 19:25 , M. Edward (Ed) Borasky wrote:

Are you behind a firewall? I’m not sure RubyGems is sneaky enough to
deal with proxy servers.

RubyGems has dealt with proxy servers for ages.

Yes, but there’s a special place in Heck reserved for the guy who
designed the NTLM proxy servers :). I have to use “aps”, which is
written in (gasp) Python when I’m behind one of those, and mess with
“http_proxy” environment variables. Can’t RubyGems do that directly?
Just ask me, “what’s your NTLM password” and go get gems? Apparently
not. Then again, neither can ActiveState’s Perl Package Manager.

On Sep 27, 2007, at 07:39 , M. Edward (Ed) Borasky wrote:

Apparently not. Then again, neither can ActiveState’s Perl Package
Manager.

If Net::HTTP can do it, RubyGems can do it. If you want RubyGems to
work with NTLM, make Net::HTTP work with NTLM.

(There is a patch in the tracker, but it looks to be windows-only.)

On Sep 27, 9:07 am, Eric H. [email protected] wrote:

C:\Documents and Settings\Milton\My Documents\Tom>gem install
rubyscript2exe -n
o-http-proxy
ERROR: While executing gem … (NoMethodError)
undefined method `[]=’ for #Gem::ConfigFile:0x2e2ebc0

This is a bug that has been fixed.

Great. I’ll await the next release.

Are you using a proxy server? If you are and you set --no-http-
proxy, you probably won’t be able to connect.

Okay.

Thanks!
T.

On Sep 27, 2007, at 07:06 , Trans wrote:

getaddrinfo: no address associated with hostname.(SocketError)
Last I checked the one click installer shipped with 0.9.4. gem env
getaddrinfo: no address associated with hostname.(SocketError)
Check gem sources to see what hosts you are attempting to attach
to. If you are having problems with DNS, no changes to RubyGems are
going to fix your DNS.

C:\Documents and Settings\Milton\My Documents\Tom>gem install
rubyscript2exe -n
o-http-proxy
ERROR: While executing gem … (NoMethodError)
undefined method `[]=’ for #Gem::ConfigFile:0x2e2ebc0

This is a bug that has been fixed.

Are you using a proxy server? If you are and you set --no-http-
proxy, you probably won’t be able to connect.

I’ve patched on my PC and posted on the ticket how I did it. The link
is
http://rubyforge.org/tracker/?func=detail&atid=575&aid=12887&group_id=126

On Sep 27, 12:07 pm, Eric H. [email protected] wrote:

C:\Documents and Settings\Milton\My Documents\Tom>gem install
rubyscript2exe -n
o-http-proxy
ERROR: While executing gem … (NoMethodError)
undefined method `[]=’ for #Gem::ConfigFile:0x2e2ebc0

This is a bug that has been fixed.

I updated to the latest SVN trunk version and got this error instead:

C:\Documents and Settings\Milton\My Documents\Tom>gem install
rubyscript2exe
c:/ruby/bin/gem.bat:19: uninitialized constant Gem::GemRunner
(NameError)

:frowning:
T.

Don’t top post.

On Sep 27, 2007, at 13:30 , Aureliano C. wrote:

written in (gasp) Python when I’m behind one of those, and mess
I’ve patched on my PC and posted on the ticket how I did it. The link
is http://rubyforge.org/tracker/?
func=detail&atid=575&aid=12887&group_id=126

This patch doesn’t have anything to do with NTLM.

On Oct 1, 2:05 pm, Eric H. [email protected] wrote:

install a gem.cmd, but either it wasn’t, or gem.bat gets picked over
gem.cmd automatically.

The install failed, and you don’t have /path/to/ruby/site_ruby/
/rubygems/gem_runner.rb

There is some other bug in gem_runner that gave a syntax error, so
svn up and try again.

Something else is wrong with your machine.

Hmmm… okay, since I upgraded from 0.9.2 (from OneClickInstaller) to
0.9.4 using setup.rb and then the same with trunk I’m assuming the
first reason you mention. I’'d delete the whole shebang and try
reinstalling.

T.

On Oct 1, 2007, at 10:31 , Trans wrote:

C:\Documents and Settings\Milton\My Documents\Tom>gem install
rubyscript2exe
c:/ruby/bin/gem.bat:19: uninitialized constant Gem::GemRunner
(NameError)

Then one of these happened:

gem.bat cannot work with RubyGems, as it is too old. RubyGems should
install a gem.cmd, but either it wasn’t, or gem.bat gets picked over
gem.cmd automatically.

The install failed, and you don’t have /path/to/ruby/site_ruby/
/rubygems/gem_runner.rb

There is some other bug in gem_runner that gave a syntax error, so
svn up and try again.

Something else is wrong with your machine.

Trans wrote:

On Oct 1, 2:05 pm, Eric H. [email protected] wrote:

install a gem.cmd, but either it wasn’t, or gem.bat gets picked over
gem.cmd automatically.

The install failed, and you don’t have /path/to/ruby/site_ruby/
/rubygems/gem_runner.rb

There is some other bug in gem_runner that gave a syntax error, so
svn up and try again.

Something else is wrong with your machine.

Hmmm… okay, since I upgraded from 0.9.2 (from OneClickInstaller) to
0.9.4 using setup.rb and then the same with trunk I’m assuming the
first reason you mention. I’'d delete the whole shebang and try
reinstalling.

T.

One-Click-Installer (OCI) encapsulates the gem gemwhich and the other
rubygems scripts into .cmd files (and remove the plain scripts).

When you install rubygems from source (setup.rb) it creates the gem
scripts and also the stubs .bat <-- note the different extension from
.cmd.

On XP/2000 platforms, .cmd is preferred over .bat files, so the old
script get run instead of the new one.

Just remove the .cmd files that match existing .bat from Ruby\bin and
guess that could work for you.

(In case you solved the no-connection-to-internet shown before)

HTH,

Luis

On Sep 27, 9:07 am, Eric H. [email protected] wrote:

gem install rubyscript2exe
Please paste the full command output.

rubyscript2exe -n
o-http-proxy
ERROR: While executing gem … (NoMethodError)
undefined method `[]=’ for #Gem::ConfigFile:0x2e2ebc0

This is a bug that has been fixed.

Are you using a proxy server? If you are and you set --no-http-
proxy, you probably won’t be able to connect.

No.

However, I deactivated the Firewalls (turns out there were two on this
machine Microsoft’s and Norton’s) and then it worked. So it’s
definitely a Firewall issue.

T.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs