One-click Installer (ruby186-25) not installing gem

Windows XP SP2
New to ROR

Every note I’ve found about installing Ruby on Rails on Windows using
the one click installer from http://rubyforge.org suggests that it
seamlessly also installs rubyGems. But after I run the installer and
open a command window,

ruby -v returns “ruby 1.8.6 (2007-03-13 patchlevel 0) [i386-mswin32]”

while
gem -v returns “c:/ruby/lib/ruby/site_ruby/1.8/rubygems/config_file.rb:
51:i
id argument - “C:\WINDOWS\DESKTOP”/.gemrc (Errno::EINVAL)” and more
lines about not being able to open the file.

Should I be defining a .gemrc file somewhere, or can I modify a config
file somewheret to point to whereever it should be and, if so, where
might the correct file be?

So far, I’ve modified the PATH environment variable to be c:\ruby\bin
and every variation I can think of, with no luck.
The RUBYOPT environment variable was “-rubygems”; I tried changing it
to c:\ruby\lib\ruby with no luck there either.

I’d appreciate any help. Thanks.

Anyone have any insights into what might be not happening correctly on
install? I’ve tried uninstalling and re-installing several times with
no change.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs