One click installer + gems


#1

Hi!

It was expected, that as of 1.8.4, ruby networking works on windows.
However using the latest installer, when I tried to install a gem
(actually rails), the gem process failed.

So is there anybody having the same problem, or can everbybody else
install gems under XP?

thx

Gergo


#2

On 2/4/06, removed_email_address@domain.invalid removed_email_address@domain.invalid wrote:

Hi!

It was expected, that as of 1.8.4, ruby networking works on windows.
However using the latest installer, when I tried to install a gem
(actually rails), the gem process failed.

So is there anybody having the same problem, or can everbybody else
install gems under XP?

I don’t have any problem.

Are you behind a proxy server? Specifically, what error messages are
you getting?

Curt


#3

No error message.
When I say: gem install rails, the last line I get is:
Attempting remote installation of ‘rails’

I connect the internet via a router.


#4

Additional problems:

cannot ping gems.rubyforge.org

The test script:
require ‘socket’

hostname = ARGV[0]
puts “Making socket to #{hostname}”
sock = TCPSocket.new(hostname, 80)
mesg = “GET / HTTP/1.1\r\nHost: #{hostname}\r\n\r\n”
puts "writing to socket #{hostname}: " + mesg
sock.write mesg
puts “Wow, no hang!”

hangs on www.google.com

Anyway, my internet connection seems to be ok…


#5

On 2/4/06, removed_email_address@domain.invalid removed_email_address@domain.invalid wrote:

mesg = “GET / HTTP/1.1\r\nHost: #{hostname}\r\n\r\n”
puts "writing to socket #{hostname}: " + mesg
sock.write mesg
puts “Wow, no hang!”

hangs on www.google.com

Anyway, my internet connection seems to be ok…

How can you say your internet connection is ok when you can’t get to
google? I can get to google and I can ping gems.rubyforge.org – there
is defintiely something wrong with your internet connection.

Curt


#6

On Sun, Feb 05, 2006 at 08:35:00AM +0900, Curt H. wrote:

puts “Wow, no hang!”

hangs on www.google.com

Anyway, my internet connection seems to be ok…

How can you say your internet connection is ok when you can’t get to
google? I can get to google and I can ping gems.rubyforge.org – there
is defintiely something wrong with your internet connection.

I think he was hinting that the problem lies in Ruby’s TCPSocket…
See [145244] for instance.


#7

I’ve read that 6 month old post, but don’t know what to do.
So how to resolve?

thx


#8

I can of course connect to google with other methods…