One click installer, fxruby


#1

i was using an older version of the one click installer, but i could
never get any fxruby programs to run. so i updated with the latest rc
version

fxruby programs STILL don’t run. now i’m wondering if there’s
something special i need to do to get it working?

http://home.cogeco.ca/~tsummerfelt1
telnet://ventedspleen.dyndns.org


#2

On 5/25/06, tony summerfelt removed_email_address@domain.invalid wrote:

i was using an older version of the one click installer, but i could
never get any fxruby programs to run. so i updated with the latest rc
version

fxruby programs STILL don’t run. now i’m wondering if there’s
something special i need to do to get it working?

could you give more info about the error? i.e. output of an fxruby
example on the shell
otherwise we can only guess what’s wrong. maybe it’s because the
RUBYOPT environment variable has not been set to “rubygems”
hth,
– henon


#3

On Fri, 26 May 2006 00:11:14 +0900, you wrote:

could you give more info about the error?

i just double clicked on the examples in

ruby\lib\ruby\gems\1.8\gems\fxruby-1.4.6-mswin32\examples

i.e. output of an fxruby example on the shell

running button.rb onn the cmd line in the above directy:

button.rb:3:in `require’: no such file to load – fox14 (LoadError)
from button.rb:3

maybe it’s because the RUBYOPT environment variable has not
been set to “rubygems”

using set RUBYOPT=-rubygems on the command line worked…

i was under the impression the one click installer did that for me.

it still won’t run when double clicked even though the rubyopt
environment variable is in both my user account and system wide
environment settings .

i can’t get foxguib to run by double clicking OR via cmd line with
rubyopt set.

i seem to be jumping through a lot of hoops to get simple gui programs
running :confused:

http://home.cogeco.ca/~tsummerfelt1
telnet://ventedspleen.dyndns.org


#4

The installer should have set RUBYOPT. It should also set the file
associate
that lets you double-click on those files. Are you running 184-17? If
so,
then something went wrong with your installation (do you have
adminitsrator
privileges?), and I would suggest that you uninstall and then reinstall.


#5

On Fri, 26 May 2006 03:12:52 +0900, you wrote:

The installer should have set RUBYOPT.

it did for the system wide env variables. i had to set it for my user
account. note, i haven’t rebooted this machine, but i did on an older
install of one click installer, and had the same problems…

It should also set the file associate
that lets you double-click on those files.

it didn’t do that, but that’s easy fix…

Are you running 184-17?

yes.

then something went wrong with your installation (do you have adminitsrator
privileges?), and I would suggest that you uninstall and then reinstall.

i was using an account that did, but to make sure i uninstalled, and
installed via “run as” with the regular admin account.

still no joy.

if i set rubyopt on the command line, i can run the examples.

i can also run the example inside komodo or arachno-ruby, so between
either of those and rubyscript2exe i can do what i need.

http://home.cogeco.ca/~tsummerfelt1
telnet://ventedspleen.dyndns.org


#6

Also, the one-click installer includes two FXRuby programs that you
should
be able to run to verify that everything is properly installed:
FreeRIDE
and fxri. You can find shortcuts to run them in the start menu.

Curt


#7

On Fri, 26 May 2006 03:08:32 +0900, you wrote:

Also, the one-click installer includes two FXRuby programs that you should
be able to run to verify that everything is properly installed: FreeRIDE
and fxri. You can find shortcuts to run them in the start menu.

and both of those run. via the batch file in the ruby\bin directory.
that’s why i posted. i figured the fxruby examples would run also…

http://home.cogeco.ca/~tsummerfelt1
telnet://ventedspleen.dyndns.org