On Console options

Hi,

I’m sure this is another case of PEBKAC but I’ve been looking in the
code
and I think that’s how it’s supposed to work.
When I want to use -X:ILDebug or -X:SaveAssemblies I assume the rbx
command
also expects the -X:AssembliesDir argument, is that correct?

Which brings me to my next point:
When I want to execute
» rbx -X:AssembliesDir C:\projects\temp\ir_test test.rb
mscorlib:0:in CanonicalizePath': The given path's format is not supported. (System::NotSupportedException) from mscorlib:0:inCreateListFromExpressions’
from mscorlib:0:in AddPathList' from mscorlib:0:in.ctor’
from mscorlib:0:in Init' from mscorlib:0:in.ctor’+ C:\projects\temp\ir_test

Ooops… I hit tab-enter… sorry for that.

---------- Forwarded message ----------
From: Ivan Porto C. [email protected]
Date: Fri, Mar 14, 2008 at 10:50 AM
Subject: On Console options
To: [email protected]

Hi,

I’m sure this is another case of PEBKAC but I’ve been looking in the
code
and I think that’s how it’s supposed to work.
When I want to use -X:ILDebug or -X:SaveAssemblies I assume the rbx
command
also expects the -X:AssembliesDir argument, is that correct?

Which brings me to my next point:
When I want to execute
» rbx -X:AssembliesDir C:\projects\temp\ir_test test.rb
mscorlib:0:in CanonicalizePath': The given path's format is not supported. (System::NotSupportedException) from mscorlib:0:inCreateListFromExpressions’
from mscorlib:0:in AddPathList' from mscorlib:0:in.ctor’
from mscorlib:0:in Init' from mscorlib:0:in.ctor’

Is that not how I’m supposed to execute the test.rb file when I want to
use
the save assemblies or ILDebug?

Thanks
Ivan

Don’t do it from PowerShell :slight_smile: You also have to pass in
-X:SaveAssemblies…

On Thu, Mar 13, 2008 at 5:58 PM, Ivan Porto C.
[email protected] wrote:

    mscorlib:0:in `CanonicalizePath': The given path's format is not

Thanks
Ivan


Ironruby-core mailing list
[email protected]
http://rubyforge.org/mailman/listinfo/ironruby-core


Michael L.
[Polymath Prokrammer]
http://blog.prokrams.com

Ah, I had only tried wrapping the path in quotes, not the option
itself…

That’s weird, do you know why off hand?

On Fri, Mar 14, 2008 at 8:50 AM, Tomas R. [email protected]
wrote:

Tomas R.
http://www.winterdom.com/weblog/


Ironruby-core mailing list
[email protected]
http://rubyforge.org/mailman/listinfo/ironruby-core


Michael L.
[Polymath Prokrammer]
http://blog.prokrams.com

Don’t do it from PowerShell :slight_smile: You also have to pass in -X:SaveAssemblies…

:slight_smile:

You can actually still use rbx from powershell, simply wrap the -X
switches in quotes:

.\rbx ‘-X:AssembliesDir’ ‘C:’ test.rb

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs