Offline documentation for ruby

Dear all

I try to run ri String in my Window command prompt, it show the
following error

‘less’ is not recognized as an internal or external command, operable
program or batch file.

Is the ri not support for window? How can I fix it?

Thank you very much

Valentino

On 23.11.2008 02:52, Valentino L. wrote:

Dear all

I try to run ri String in my Window command prompt, it show the
following error

‘less’ is not recognized as an internal or external command, operable
program or batch file.

Is the ri not support for window? How can I fix it?

Try setting environment variable PAGER to more, e.g.

set PAGER=more

No idea whether that helps. I can’t test it because I don’t use the
Windows distribution.

Kind regards

robert

On Sat, Nov 22, 2008 at 5:52 PM, Valentino L. [email protected] wrote:

I try to run ri String in my Window command prompt, it show the
following error…

How did you install Ruby on Windows?

I’m using the One Click Installer (Ruby 1.8.6), and “ri String” works
just fine (on XP and Vista).

Hope this helps,

Wayne


Wayne V.
No Bugs Software
Agile Ruby (but preferably not Rails) Contract Programming in Silicon
Valley since 2001

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs